Snowman Family File Not Opening

I have premium and have printed this file a few times. I went back in to print again and now it won’t open, it’s stuck on rendering file. All of my other files seem to be opening fine, just not this one. What am I doing wrong?

1 Like

You probably are not doing anything wrong. Try using a different browser or downloading the file again from the catalog.


I’ve tried 3 different browsers, 2 different computers. Since it’s in the glowforge catalog it won’t let me delete and re-download it. I have tried to open it directly from the catalog again but I’m still getting the same result :frowning:

Reset the design. I think it is on the menu.

1 Like

I can’t even get there, none of it opens

Oh no! I am sorry to hear about the trouble. We are seeing this too and will provide you with an update as soon as we have more.

In the meantime, while we continue to investigate, I went ahead and just pushed a new version of “Build a Snowman Family Ornament” to your dashboard.

Let me know if you have any further trouble with the design.

1 Like

Hi Danielle, i have been having the same problem can you please help? I have sent an email.

Please open your own support post separately. Support can only address one post per person at a time.