Software scaling Issues for small scale parts

Hi Everyone,

I am looking for some advice please. I am creating very precise small parts and having a software issue.

I am working to mm and parts of a mm for scaling project files. If I make a file at 917 high by 210 wide, it imports into the glowforge app software oversized. Is there a way of preventing it from doing this please?

Similarly, when they do import and the scale is off, I know you can re-scale via the rulers. But, I have found that unless I am not zoomed in to far (so as to see the entirety of the object I am trying to scale) it will not actually scale. If I zoom in so that I can do say 196.5mm wide, click the corner and scale in, I then zoom out and find that instead of scaling, the object has actually moved left off of the rulers. I have tried time and again, made new files etc.

Any and all advice / workarounds would be super appreciated as this is driving me a little crazy & sucking up much additional time - it is really problematic. Thank you - otherwise, love the machine!

Thank you :slight_smile:

What software are you using to create your files? What format are the files?

1 Like

While much over sized, if you create the project with a size comparable to the size of the glowforges bed, that can stop it from resizing some things. PDFs tend to keep their size. Some programs save utilizing settings that are smaller than what the gf expects and so they get resized.


There are lots of scaling issues with various design programs that can cause this – the thing to know is that Glowforge assumes a scale of 96 DPI, but since scale isn’t included in SVGs that means if your software thinks things should be 72 DPI or somesuch, they’ll be the wrong size in the GFUI.

Now that you know that, instead of having to dig through settings and defaults and export rules and stuff, just make your artboard 20" long by 12" high (508 mm x 304.8 mm). The GFUI recognizes that particular proportion and will automatically size it correctly for you. :slight_smile:


Hi Hansepe,

Thank you - the files are Photoshop of origin, I normally save as PDF as it is an older computer (Mac) then use Inkscape to change them into SVG so that they can cut.

1 Like

I believe Inkscape is the most well know example of what @geek2nurse is describing with the dpi sizes. I use illustrator so I don’t know where the settings are to change the dpi from 72 to 96. But that should solve the problem. Illustrator has its own issues.

1 Like

You know you can load PDF files directly into the GFUI, right? Try skipping the Inkscape step!


Or there is that. :laughing: trying to simplify! Ha!


Hi Geek2nurse, Hi WesleyJames,

Sounds like a fabulous workaround, Thank you so much - I will give it a shot! I think it is the DPI - just looked, mine are up at 300 as they were initially created for use on a K40 way back :slight_smile: I left them high thinking the higher they were, potentially slower loading times but the better line quality may be (thinking regular printers obviously - not these, a different breed.) Thank you both!

1 Like

I’m sorry you ran into trouble when importing your design. It looks like you’ve already received some fantastic advice from other community members. Thanks folks!

@amberlouise86 will you please let us know how it goes? If you still run into trouble, we’ll be happy to help.