SOLVED: Lid Open continues after replacing lid cables and sensors

My glowforge displays the lid open message when powered on. I replaced both the black cable and the white cable and it didn’t fix the problem. Next I tried bypassing the sensors in the lid and it still had no effect on the problem. Does anyone have a suggestion on what to try next?

Round trip shipping for repair will cost me more than $500 , so it’s not feasible for me. If I can’t repair it myself it will go in the trash and I’ll look for a different brand.

A working Glowforge is worth $3000-5500 on the used market. Getting yours fixed will not cost you half that, including shipping. There is no world in which it doesn’t make sense to get the machine repaired, even if only to sell it and use the profits to buy a different laser from another brand. If you’re going to throw it in the trash, I’d pay you to ship it to me instead, then get it repaired.

8 Likes

Sounds like a hardware failure, most likely linked to that small PCB that the black ribbon cable connects to. It can easily be shorted/damaged while cleaning (it is not meant to be touched).

1 Like

Noooo. Even in pieces it’s worth money. I will never pay to have mine returned. I know it’s going to die someday but I ain’t throwing it in the trash lol. Somebody will need parts and I’ll sell them.

3 Likes

After it didn’t work when I bypassed the sensors by connecting the sensor wires together, I decided to try shorting the sensor pins on the LED cable itself. When I did that, the glowforge recognized the lid as being closed. It turns out that the connector on the left sensor cable was not manufactured properly. When the connector is plugged in, the pins inside do not reliably contact the pins on the LED cable. I forced the sensor cable pins deeper into the connector shell and after doing that the lid was recognized as being closed.

10 Likes

Glad you solved it!

2 Likes

That’s awesome! I am not knowledgeable in that area and never would have thought of doing that. Way to go!

1 Like