Speed Problems

I just received my third Glowforge. The first 1 didn’t cut at all, and I was then sent a refurbished one, which also didn’t cut. Each machine had lots of tests done to make sure I wasn’t doing anything incorrect.
I’ve just received the third printer, and it is so quiet and very slow compared to the other 2 machines. It gets pretty smoky on the inside, and the fan doesn’t seem to suck the smoke out very fast. It cuts, which is great, but just incredibly slow
I’m not very experienced with the techy side of the printers, as I haven’t had a working one long enough to discover all the settings. I did change the speed to full power, and it still cuts very slow. Perhaps something else needs to be changed as this is a refurbished machine. Would love some advice please

First lets address the smoke and quiet issue. In the interface, with a design open, click the three dots at the top of the interface to the right of the T. When the menu drops down, make sure that “Glowforge airfilter attached” is toggled to off (left). I believe that your machine is setup for an inline fan or an airfilter.

As for the speed, I don’t think this machine will be any faster or slower than your previous machines. You said that you changed speed to full power - but that is not a speed setting, that is a power setting. There is no full power speed setting.

1 Like

Thank you.
Looking at the drop down menu now, ‘glowforge air filter attached’ is toggled to on, but it won’t allow me to toggle it off. It’s in light grey print and won’t let me select it. The only thing it allows me to do is hit the question mark beside it, and takes me to Glowforge Air Filter Manual.

Click just to the left of the toggle and see if it will switch. Click all around and see if you can get it to move. Until it flips, you shouldn’t use the machine because you need the exhaust fan running to move the smoke out of the machine properly. If you can’t get it to switch, Support will see this post and contact you. You can also try emailing them. Glowforge tech can switch the toggle if you can’t get it to change.

1 Like

Yeah, I’ve clicked everywhere and it’s not going. Thanks for all your help. Appreciate it. I’ll send off an email tomorrow.

1 Like

Whoops, Glowforge messed this up a bit when they sent you the replacement machine.

The option being greyed out means you’re not listed as the owner / administrative user of the machine in their system. For example, you can share access to a Glowforge with other people (like family members) who get their own accounts, but they can’t change certain settings the owner account can. The support staff will be able to fix this for you.

Once you’re able to flip that switch back, the exhaust fan will pull smoke out of the machine while it’s cutting things. Chances are your new Glowforge is great and this will be your last bit of inconvenience before you’re up and running and making cool stuff with it!


Thank you Dan. Yes this happened on my last machine as well (not the fan issue but someone else’s name was still on it). I did check, and you’re right, the old owner is still listed.
Thank you for the advice. Hoping to be up and running for tomorrow!

Hi @breannacoxon. I sincerely apologize for the delayed response and sorry to hear that you ran into some trouble with the toggle switch for the Glowforge Air Filter setting with your printer. I was reviewing the log files and noticed the option for the new printer appears to be off now. Can you confirm if you are still seeing it turned off, or if you’re continuing to notice issues with smoke, or the exhaust fan spinning slower than expected? Let me know any updates and I’ll be happy to work with you to get this resolved soon. Thanks!

Thank you for the response. I’ve worked it all out and everything is working great now.
Many thanks!

Hi @breannacoxon. That’s great news to hear! Thank you for following up to let me know. I’ll go ahead and close this thread, but feel free to create a new thread, or write us at support@glowforge.com if you run into any other trouble. I’ll be happy to help.

Happy printing!