Steps for Save and re-Open for re-ordered engrave list


#1

New to Everything including Everything. May even be posting incorrectly.
Anyway I finally got a 16-step engrave to run (Yeah!)
Through some means I find I have an htm file that was saved. When I open this in my browser there is a quick flash of the svg image, then a message " We’re sorry, an unexpected error has occurred.
If the issue persists, please contact us at support@glowforge.com with details about what’s causing this error to occur."
Can anyone list in detail steps for

  1. Saving the Dashboard project which has the re-ordered engrave steps and parameters,
  2. How to get that save information back onto a new dashboard session?
    mrquest requests HELP!

#2

Just closing the Dashboard project should save it automatically now, just as you left it. Make sure when you reopen it, you use the same material or the settings might change.

When you re-open the file from the Dashboard it should open up just like you left it last. (So don’t delete anything - it will go away now. Just drag unwanted parts off of the artboard so they don’t print.


#3

Oh Thank You, Jules.
But on the Home page, clicking on Open generates an Error mentioning something about “clip-path” being unable to be processed. I have no idea how a clip-path got generated using Inksacpe.
The Dashboard comes up with no artwork. Not sure how the file ever ran if it now won’t. I was hoping the htm file was somehow uncorrupted. Looks like I have to start all over.
mrquest


#4

Did the original file have a clip path in it? Sometimes a raster image with a white background will create one, but it still should have opened.

If you want to zip the SVG file and load it up here, someone can take a look at it.

(One other thing, you want to save the Inkscape file as a Plain SVG file type, although I think the GFUI can handle Inkscape SVG files…but maybe it introduced an error. You don’t need the htm file.)


#5

4X4 Matrix.zip (3.3 KB)

Jules, I am not sure if I’m sending to the correct “here” you wrote about someone taking a look at it.
Now my already uploaded files on Home screen give me black screens on the GFUI Dashboard, although the various pieces are seen in the left-side bar.
Hard to make progress.


#6

Yeah, loading it here (forum) was what I was talking about. I’ll try to load it and see what happens.


#7

Okay, I can’t find a clip path in there, but it doesn’t impact the ability of the GFUI to process it, so it should be fine, even if you get an error message.

Try closing the app and opening it a couple of times to see if it clears those black fills…that’s been happening lately, we think there might be a bug. Also, avoid using the Add Artwork button and the Upload button…just drag and drop. It seems to be a bit more stable until they squish that bug.

Might not have been anything you did. Bad news to lose all of the engrave settings though.


#8

On Dashboard I Logged Out, logged in to the app, which leads to Home screen. Can’t get to Dashboard without Open something already Uploaded. Black screen again with the correct pieces of the artwork shown in lefthand column. Now tried Drag another plain SVG on Dashboard. It took the Copy, then again showed the dark screen with new pieces of that SVG added to those already in the left column. Couldn’t select/move/delete anything on the dark Dashboard.
What seemed to work: from machine state described above, clicked on Glowforge lightening icon, clicked on Settings, clicked left arrow to return to previous screen, finally get all loaded artwork to show. But also got the Error “… can’t process clip-paths …” Guess I will try to run it anyway. Could the app have a bug that triggers the clip-path error when there is no real error? I can’t find any clip paths.

So frustrating. Thank you for your help.


#9

Opening the file in Illustrator doesn’t show any clipping masks to release. However, looking at the actual SVG code shows that each engrave element is being defined by an SVG clipPath command.

Every rectangle looks like this in the code:

< clipPath
id="clipPath2367"
clipPathUnits=“userSpaceOnUse”>
< rect
ry="2.54"
rx="2.54"
y=“186.534"
x=”-1.263751"
height="67.743713"
width="64.928299"
id="rect2369"
style=“opacity:0.20100002;fill:none;fill-opacity:1;fill-rule:evenodd;stroke:#00ff00;stroke-width:0.09999999;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1” />
< /clipPath>

I resaved the document in Illustrator.

Matrix 4X4 test engrave_noClipMask.svg.zip (2.1 KB)


#10

So they really are there.
I see these clipPath invocations when opening the old SVG files in Wordpad.
Now I have to find out how Inkscape generated these when I make these drawings.
Whatever is happening happens to many of my attempts at using Inkscape. At least now I can check the SVG file using Wordpad.


#11

Just discovered that if I drag the plain svg file directly onto the Dashboard (no Upload from Home window), I get only 5 of 16 squares showing as pink on the Dashboard. Rest are blacked out even though the left hand column shows all 16 Engraves.
A search with Wordpad showed no clipPath invocations in the plain svg file.
What worked: On Home window, Upload file. Now all 16 squares show as pink squares and I set the engrave parameters for each and reorder each.
Looks like I must go through the Upload step.


#12

I’m glad you found a solution and sorry it was such a challenge. We’re investigating. Please open a new thread if you have further questions on this or other topics.


#13