Still getting "This design has text" warning after converting text to path in Inkscape

Not sure where to put this question, hopefully here is fine.

I have been using Inkscape and Glowforge for a long time, and I’m just curious, why do I still get a “This design has text” warning pop-up when uploading a file, even after I have converted the text to path in Inkscape?

After poking around the forum I think it’s just a remnant from Inkscape that clocks the object as text, even after it’s been converted and acts like an object.

I know I can just ignore the warning pop-up and close it out, but I’m interested in selling my files on Etsy and I would really love customers to not get confused by it. It’s a pretty intense pop-up if you don’t know what’s happening.

This feels, at this point, like a GUI support issue? Does that seem right?

Also, does anyone know, if I open my files in Illustrator or Affinity Designer, and re-save them, will that get the pop-up to stop?

Many thanks!

If you click on the text in Inkscape and it doesn’t say text, the Glowforge should process it without issue. I have had plenty of times when I thought I had converted the text in Inkscape, but Inkscape continues to identify the object as text. Maybe share your file or make sure you are saving the file as a Plain SVG in Inkscape.

As to opening the file in AI or Affinity Design, why not try it and see what happens.

1 Like

I’m not fully parsing this, specifically the part where you say “I have had plenty of times when I thought I had converted the text in Inkscape, but Inkscape continues to identify the object as text.”

Do you mean you had forgotten to convert the text to path? I get that, but I am fully convinced that I am doing everything possible to convert the text to a path. I select the text, then use Path > Object to Path. I also play around with combining the object and manipulating them.

I always get the “This design has text” pop-up in the GUI. I’m super curious if it’s true that you convert text to objects and then dont get that pop-up, that means it’s possible and would point more closely at an answer.

Well, I plan to, but it’s always a good idea to ask questions and see if there are answers. Adobe and Affinity Designer cost money, it would be nice to know if it would actually solve my problem first.

1 Like

Ah, yep. Here’s a few screenshots to show these are not text objects anymore. And yeah, I’m saving them as plain SVG.

and another because yes, I understand that there is text in that last screenshot. I’ve converted it.

Click on file then “clean up document”, save and try again? you might have a blank text field somewhere in the background.


It’s not complaining about the notes/instructions?

Nope, those have gotten the Path > Object to Path treatment, and besides that this is not a new problem for me, it’s always happened, even before I added that text to the file and it was just the vector design itself.

Sometimes I’ve seen this when there is a spurious, empty text object in my file.

In theory you can just ignore GF’s warning if that is the case… but it might be worth making sure. If you wanna send me a SVG to check for you, happy to help.

I’d just open the SVG in a text editor, and look for “<text”


Well first thing I’d delete those notes regardless if you’ve converted it or not before you go to cut/engrave. When you load it into GF, does it have all the right cuts and engraves? If so then what primal said is probably true. Blank text field somewhere hiding.


That’s an interesting one, I’ve never used it before, but alas it has not worked :slightly_frowning_face:. Thanks for the suggestion tho, I’ll keep an eye on that function in the future.

Press ctrl+6 and it will give you this neat slider to help find hiden things

Maybe something will stand out with that, If not you can send me the file and i can take a look


These are also interesting suggestions, but I suspect not the case. Here’s the file if you want to check it out, and thank you! (anyone curious is welcome to check out the file, I’m curious if other people get the pop-up)

I did try to open the SVG in a text editor, because I’ve never heard of that, but didn’t come up with anything. I really don’t think I have any mystery text files hanging out, which is why I said in the original post that it feels more like something Inkscape does, leaving some remnant of the fact that the object was text. I’ve seen other people make slight mention of that elsewhere in this forum. :woman_shrugging: queer-heart-earring

Very strange, no idea where it is coming from. tried all the things i know and it still shows up. the only way i got it to go away was to select all the shapes and re save it into a fresh inkscape project.
queer-heart-earring resave

1 Like

Huh, I don’t seem to have that function. Though, as a side fact, I have had to use a janky version of Inkscape because I have it on a Mac laptop. So not all of the functions translate.

Here’s the file if you want to take a look, I would be particularly interested if you or anyone else can get this file to open in the GUI without the text warning pop-up. Feel free to delete the text if that makes anyone feel better, I’m more interested in the core earring files because those have always gotten the pop-up. If anyone can do this, that’ll give me a formula to work towards. Maybe I just need to use Inkscape…not on a Mac :rofl: I will genuinely lol if that is the case.

Oh WILD. This does support my thought that it might be my version of Inkscape, it truly is pretty jank at this point because of all the terminal installation crap I had to go through to get it on my Mac.

But it works when you re-save it? In your version of Inkscape? That’s fanstastic news! If you don’t mind, what type of comp are you running it on?

It works only when i select all the objects in the project copy them and then paste them onto a blank project and then re save. I think there is a newer version of inkscape for mac but im a pc user running windows so i cant help you there.

1 Like

This is actually super helpful! It gives me a promising thing to try, since I probably don’t have the most recent version of Inkscape. Thanks! I’ll try that and might even come back and update if I get that working. :grin:

1 Like

You might be able to find a better version here. Hope that work around helps out.


If you look at the SVG code, the first bit has an empty text node:

All that code is just an empty text node. It won’t render anything, but it will cause GFUI to give that warning.

If you look in Inkscape at the “Objects” view, and you clean up things in there, you may be able to remove these.

I can see ‘text1046’ in that list, which seems like at least one of the culprits.