Stuck on Homing/Centering -- Head Not Moving

I was using my machine this morning with no issues. I turned it off and recently tried to turn it on and load another file to engrave. When I turn it off, it does the initial clicking and then makes the sound like it is centering/homing; however, it is stuck on that. The head keeps making a sound like it wants to center but it wont leave the top left corner.

Things I have already checked:

  1. Internet is on and working
  2. Lenses are clean
  3. There is nothing obstructing the arm (moves front to back no issues)
  4. There is nothing obstructing the head (moves left to right, no issues)
  5. All 5 clips on the lid are fully intact/straight.
  6. Temperature is perfect where GF is located.

Here’s the official troubleshooting list–you’ve hit some of the points already, but there are more things to try:

Note that even if your Internet is working, the GF is pretty picky about its wifi signal, so don’t skip over the parts for ruling that out. :slight_smile:

1 Like

Found a comment through another post: remove all items from tray and let it calibrate with nothing on the tray and then add the wood in… worked like a charm! Thank you!

1 Like

Yep, that’s one of the steps. :slight_smile:

I’m glad you resolved it! Thank you @geek2nurse for your advice. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!