Stuck on Offline/Homing/Scanning

Hello - my Glowforge Pro has been stuck on Offline/Homing or Scanning for about 2 weeks now. Occasionally, I can get some work done but today, not so much. I have tried cleaning all the lenses and surfaces, removing everything from the bed, resetting all WIFI connections, logging in and out of the app and restarting/unplugging multiple times.

Is there anyone who has other suggestions or can help at GF? Thank you!

1 Like

Try turning it off, then gently move the head under the lid camera and then turn it back on. This may or may not work, but it’s a shot…

Thanks @gamn1958 - I forgot to mention that I have tried that as well with no luck!

1 Like

I think you have a wifi problem. The Glowforge is extremely picky about its signal.


You’re welcome, I was hoping for you…

1 Like

Just got the “ready” prompt, so I am currently printing. (yay!) But, I know that this will happen again - so I just need to figure out what’s going on. Thank you for your response!

1 Like

You are very welcome and @beerfaced is right, the GF is very picky about the signal strength and it must be a 2.5 Ghz channel of the Wi-FI. I had to install a booster right next to mine when I moved into my shop.

1 Like

That it’s working on and off pretty solidly posts to an issue with your WiFi. You need a solid connection, not so much a fast one. There are online tools - or you can call your ISP - and find out what your db latency is. You’re looking for one under ~60 (the lower the better). Also, a lot of ISPs are “upgrading” routers to 5G whenever that signal is stronger, but the :glowforge: only works on 2.5G, so possibly see if that’s the issue. Folks have had success creating a private 2.5G network that only the :glowforge: logs into to solve that particular issue.

1 Like

@beerfaced and @gamn1958 - I hope you’re right because that would be a much easier solution. With 3 kids at home schooling and hubby working, etc… our WIFI is just not the same anymore. Thank you so much!


@deirdrebeth - thank you so much - we will be looking into all of this. (we have a family of 6 who have been using WIFI like crazy this year.)


Our was working for everything but one of us couldn’t zoom…which is just odd. We had a tech come out and it turns out we still had the modem from when the house was first purchased…15 years ago? They upgraded that and despite no difference in our speeds our latency went down by like 10 points and she’s now able to zoom.
Sometimes it’s weird things!


I am guessing your WiFi router isn’t working well with the Glowforge.

Your internet connection and your WiFi aren’t the same thing, in case you aren’t aware of that. Your Glowforge is very picky about interference on the radio frequencies that are used for the WiFi and this often causes errors like this.

Sources of interference can range from your microwave oven, a 2.4 GHz cordless phone, other WiFi devices, your neighbors’ WiFi signals, and more.
In addition, if your WiFi router that creates the WiFi signal is not able to handle the number of devices that are asking for the WiFi access and the traffic they generate, the Glowforge may be getting errors from the router as the router attempts to prioritize what it sees as more important traffic.
With six users on the WiFi, you may need to look into a different router with better multi-connection ability or a mesh WiFi system that can help handle the load.
In my experience, the ISP has only looked at the speed or stability of the internet connection between my modem and their system and doesn’t deal with the WiFi signal, but depending on your service they may be able to look at the signal inside the house.
If not, there are WiFi signal strength apps for smartphones. If you get one of these, you are looking for a consistent signal strength of -55 dB or higher at the Glowforge. If your signal is lower, the Glowforge will have trouble keeping the connection to the servers and will have problems.

I use a Plume mesh WiFi system and it is rock solid. My Glowforge is about 6 feet from one of the nodes and has never had a hiccup in the entire time I have used it. I also have other 2.4 GHz-only devices and they also handle the Plume mesh WiFi easily and are stable.

1 Like

Hi @sibylsmith,

Thank you for reaching out. I’m sorry to hear your Glowforge is having connectivity trouble.

I just took a look at the logs from your unit, and the group consensus is correct, the issue is your WIFI connection. I can see your Glowforge is able to connect successfully to your network, but is having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

I’ve extracted some data from the last few days of use in order to investigate. In these logs we have a record of the average signal strength the Glowforge is capturing from the network it’s connected to.

On average, this signal strength has been low over the last week, with average strength at around -74dBm as of today. For more context, on networks with very good signal strength, this will often run closer to -30dBm. A signal strength at -70dBm or lower would be very difficult to stay connected to.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, I have a couple of suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

I hope this helps. Please let us know how it goes.


@ben1 - thanks so much for taking the time to explain - we will look into all of this and are hoping for a quick resolution!

@MorganW - thanks so much, we will work on all of this and hope for a quick resolution!

@sibylsmith, That sounds great. Please keep us posted on how it goes. Happy New Year!

Hi @sibylsmith,

It has been a few days since we heard from you so I wanted to check in and see how things are going. I just took a look at the logs from your Glowforge and see that you were able to successfully connect and print yesterday, but that you network signal strength is still low.

Were you able to try the steps I provided previously? If so, did you notice any improvement?

1 Like

Hi @MorganW - thanks so much for checking in. Interestingly enough, I have not had issues these past few days, but, we are prepared to deal with WIFI issues with another network, etc. in the near future. I will definitely let you now if I have further questions/issues and I appreciate you checking back in. Happy New Year! ~Sibyl

1 Like

Hey @sibylsmith,

That’s great news! Since things are going good, I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!