Stuck on Rendering Design for multiple Days


The past 48 hrs I’ve been stuck on Rendering Design no matter what I do. I can’t open any of my designs. I can open a new design but none of my old ones that I need to complete orders.

I’ve upgraded my xfinity internet, moved my modem closer to my glowforge, purchased a WiFi extender and plugged it in next to my Glowforge. Restarted my computer and WiFi. Tried a different internet browser, deleted all Cache and data.

I spoke with Xfinity and they said my internet speed and connection is at 100%.

I need my machine to fulfill orders and all I’ve received from Glowforge is how to improve my WiFi but I feel like something is wrong with the Glowforge app.

1 Like

There is no GF app, so any computing device with a web browser will work. Try a tablet, or your cell phone, or someone else’s computer or laptop. If they all don’t work either, you have more ammunition for your discussion with GF. If one or more of them work, you know the problem is with your computer.

You have not listed “restarted my Glowforge” as one of the troubleshooting steps you’ve taken. Have you?

1 Like

Thank you for the advice about using a different device, I will try that out. I have not tried restarting the Glowforge. I’ve turned it off and unplugged it but I don’t know how to restart it.

Turning it off and then on again is restarting it.

I’ve done that a bunch of times. I’m able to create new files now but once I exit out of it and then try to re-enter the file says “rendering” and still unable to use old files. I tried on my phone and ipad and still nothing.

If you can reliably replicate the issue, I think GF ought to be willing to pay more attention to you. From your description it sure sounds like a bug in their software someplace. The “Rendering” is happening on their servers. The hang condition could be a bad network connection, which is clearly what GF was thinking. But if you can reliably open and cut a file 1x, but never reload it again afterwards, that doesn’t sound networky to me.

I disagree with previous statements; this sounds like a connection issue with your WiFi or your internet connection and I would restart the internal network devices by unplugging them and then starting each up in series from the wall, allowing the first to boot fully before starting the next. Modem- router - Glowforge - PC, etc.

If the issue persists after that you may have another issue and you can provide this data to your support rep when they get in touch with you.

It seems like a Glowforge issue to me as well. On this forum I’ve seen other people post about this same issue in the past and many others had the same issue at the same time but I never saw how it was resolved.

1 Like

I will try to reboot all devices in order and see if that works, other than that I believe my WiFi is at full strength. Is there an easy way to get Glowforge customer service to help? I’ve only received copy and paste type answers

It’s less about WiFi strength and more about stability. One way to rule out an issue with your modem is to connect your GF to your cell phone’s hotspot instead of your WiFi and see if you still have the same rendering issue.

1 Like

Every time you email Support that isn’t a reply to an open ticket you open a new ticket. Every time you post a new discussion here under Problems and Support you open a new ticket. New tickets from the same user slow response time. This is explained in the sticky post at the top of the topic.

The easiest way to get support is to either email or post here, not both. If you want community support, post here, if you don’t, only email. Then answer fully and completely all questions you are asked and provide all the documentation you can. The more detail you can provide the easier will be to assist.

Then you will need to have patience and wait for Support to reply. Repeat until the problem is resolved.


Hey there @brianpmartin32,

Thank you for reaching out to us and for providing a breakdown of all the troubleshooting you have done so far. I’m sorry to hear your Glowforge is having some trouble, but please know we’ll do everything we can to get you back up and printing as quickly as possible.

I took a look at the logs for your unit and it looks like your Glowforge is able to connect successfully to your network, but it may be having trouble maintaining a stable connection.

In these logs we have a record of the average signal strength the Glowforge is capturing from the network it’s connected to. On average, this signal strength has been low over the last week, with average strength at around -69dBm as of today .

For more context, on networks with very good signal strength, this will often run closer to -30dBm. A signal strength at -70dBm or lower would be very difficult to stay connected to.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet, which it sounds like you have already done.

I have some additional suggestions that may help:

  • Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

  • If your Wi-Fi network includes several access points, it’s possible that your Glowforge needs to re-establish its connection whenever it ‘hops’ from one access point to another. As a test, you could try creating a dedicated access point for the Glowforge to see if that helps.

  • Since Glowforge only uses the 2.4GHz frequency, a connection will be harder to establish and maintain on a crowded 2.4GHz network. Other devices using 2.4GHz, like cordless phones and microwaves, can cause interference and an unstable connection. You can consult your router settings to check the performance and traffic on your 2.4GHz network.

  • In your network settings, check the channel you’re using for the 2.4GHz band. Trying a different channel may provide a more consistent connection.

  • Though less common, DNS or name resolution conflicts may also cause intermittent connectivity problems. If you use a custom DNS configuration on your router, you might want to try default DNS settings to see if that works better.

As @randy.cohen mentioned previously, there’s a test you can try that will help us narrow down the problem. If possible, could you please create a Wi-Fi hotspot with a cell phone and use that network to connect your Glowforge to Wi-Fi? This is a good way to rule out signal interference, since you can set your phone right on top of your Glowforge!

You can find instructions online to help you create a Wi-Fi hotspot using a cell phone. Make sure that you set it up to be a 2.4 GHz hotspot, since that is the frequency your Glowforge uses.

Once the Wi-Fi hotspot is broadcasting, you can connect to it by following these steps:

  1. Turn on your Glowforge.
  2. Wait 30 seconds. Then hold down the button for ten seconds until it glows teal.
  3. Navigate to and follow the instructions on-screen. When prompted to connect your Glowforge to Wi-Fi, choose the hotspot you created.
  4. Once Wi-Fi setup is complete, go to and try a few prints.

Please let me know how it goes after trying the steps above. Thank you!

Hello @brianpmartin32, I just saw in our system that you also have an active email ticket open for this issue, and we have been working with you there as well.

To avoid duplicate communication, I’m going to close this thread and will continue working with you over email. Thank you.