Stuck on “rendering” for already loaded designs

It gets stuck on “rendering” for all my designs that were already loaded and saved into the print app. The only way it lets me get to the actual print section is if I start a blank design and then it won’t let me use the font, shape or insert art feature. It just acts like I haven’t clicked anything and stays blank.
They are all designs I printed this morning and had no issue with until after 12:00 and everything just got stuck on “rendering”.


If I have issues I always these two links to see if maybe GF or Google is having any issues. Just a good place to check…

I am having trouble too - yesterday it was going really slow. Today I cut one thing and now its stuck. I’ve restarted, cleared my cache, even went in and deleted christmas designs and its still not working. Of course I have orders to do today!

I’m having the same issue. I put in a ticket and they sent an auto reply about cleaning various parts but none of that helped me. I find I can upload various images from the glowforge library … but not all, and it didn’t actually engrave anything, although it went through the motions. I can’t use any of my designs, I can’t add text or shapes. LOL and like others here today finally some orders came in.

Have you tried resetting your WiFI?

No. But if others are having the same issue today it seems more likely to be an application error, right? I don’t want to keep messing with things and mess something up that was working. I’m new to it all and it makes me a bit nervous.

If my wifi wasn’t working would the head actually move? I didn’t think my computer would even talk to the glowforge if my wifi wasn’t working right?

Looking at their status I don’t see any issues, but they could still be having some or as with any application it can get stuck in a endless loop.

If I’m not mistaken, the file goes into the UI on your computer first and then when you hit print sends it to the cloud where the print is then processed and then sent back to printer for you to print. So it could be stuck with the upload to the cloud or the download to the printer.

Could be an application issue, but I haven’t had any issue. When I do have issues my procedure is this, turn off the GF, restart your computer, once that’s up and running, then reboot the WiFi, then when that’s running again on the 2.4 Ghz channel, open the GFUI app and turn the GF and once it has gone through it start up procedure try uploading some files.

Always fixed my issues…

I’m sorry that you’ve run into trouble recently while using the Glowforge App. Thank you for bringing this to our team’s attention. I’m looking into this with my colleagues now, and we’ll reach back out here if we need additional information while we investigate.

1 Like

Thanks so much. So I realized one of my great fears today… I put the machine back together wrong and I melted a piece of the plastic. And so goes life … LOL . So hopefully this issue will just clear itself up when I get the new part. LOL. Again, thanks for your help. I really appreciate it.

1 Like

I am also having rendering issues since yesterday. It was very sudden after printing the same design just minutes before. I am also having problems with creating very simple outlines for shapes. This problem started happening at the same time as the rendering issues.

I have restarted everything multiple times and had an hour long chat with my internet provider who assured me that nothing was wrong. I just was able to upload a new file, but now I’m stuck on trying to make an outline. VERY FRUSTRATING when you have orders to fulfill!

I’m thinking with several of us having the same issue is has to be a glowforge thing. These are files I’ve cut before with no problem. I noticed yesterday a slowdown. I’ve restarted everything multiple times, cleared my cache and reconnected to the internet with no results.

1 Like

Yeah I’ve reset and let my internet stay off for a moment a couple time. I turned off my device and made sure it’s all updated as well.
I normally use safari so I tried the google app as well just to see and it has the same problem.
I’m now able to open a couple of the saved files but it doesn’t seem based on the size of the design file because a few of them are larger and some are smaller. It still has issues with the professional services that I normally utilize like outline, shapes and the pre-loaded art.

I’ve done all that more than once today. I can’t open any files. I’ve been able to re download one, but needed to make an outline and it gets stuck on outline.

I’m having the same exact problem. Never had issues rendering before. Glowforge is communicating, because it is showing updated images of the bed if I switch material.

I’ll open my own ticket.

Thank you for your patience while our team looked into this further. We’ve now made a change on our end. Will you please log back into the Glowforge App and let me know if the trouble has resolved?

Let me start! I’ll be back soon

its working for me - thanks!

I printed one premade one totally perfectly. I went in and used the glowforge professionals tools to make a quick design and outline like I normally would and that looks like it’s printing amazingly too!! Yaaaaaaay! Hahahaha I’m so grateful

Yep totally going through multiple designs, shape changes and loading premade ones and it’s back to its normal awesome self!