Stuck on Rendering your design

I have one design that will not open. It’s stuck on rendering your design and I’m sure that I added too much and the file is now too big. I have tried everything including waiting half an hour for the file to open.

have you tried to ‘simplify it’ ?


It’s a file only on glowforge.

I was using it early and I was trying to make a copy of something in the design and it wouldn’t make a complete copy there were piece’s missing. So I backed out of it to refresh it and now it won’t open.

OK, is the file on the screen? click the 3 dots on the upper right, EXPORT THE FILE, open the .svg and see if you can re-create the missing parts…

No file. Just Rendering your design

WAIT, I am confused… WHAT DESIGN, can you .zip the file and upload it here?
where is the original design you started with? or did you create it all on the Glowforge?

I created it on glowforge

Try clearing the cache of your browser. That usually resolves such hiccups.

Yeah I tried that. No good

I really need this design to open and I don’t have an exported version.

Have you tried a different browser or device?

Do you have a past print available?

I can’t open it so I don’t get any options.

One thing that worked for me one time, was to create a new blank design, and then open a reluctant file from the Dashboard. There is no logical reason for why this would work, but it did.

1 Like

Ive had this problem all day. Its all my designs, all very simple so made on the glowforge app. I’ve tried every browser, tried all tips. No luck. I really need to send these items tomorrow I’m so frustrated that I’ve spent all day on this computer googling what to do!

I know you have tried everything, but clear your cache and change browsers. Restart the app (even if the machine is not online) and load the Gift of Good Measure. What happens?

That one pops up immediately. I saved one of the premium designs (happy camper studs) and it does the stuck on rendering design as well. Almost immediately it pops up on the bottom right corner FAILED TO LOAD PLEASE TRY AGAIN when I use safari, if i use chrome it just never loads. Ive waited hours walking away lol.

It’s been happening to me for two days. Glowforge emailed me back and said it was fixed but it clearly not.

Same. I’m about to lose it. I’m going to have to refund customers if it’s not fixed by the time I get off work today. I guess this is why people don’t use the glowforge app to make things