Stuck Stuck Stuck Stuck Stuck Stuck Stuck A bit Frustrated now... :/

Hi there,

It seems that every update we are thrown to, we get some problem! :confused:
First I was getting stuck in Centering, Then, Stuck in Scanning, Reset wifi, did everything we normally are told too…

Come on… what’s happening with you guys ?

Sorry but it’s not as reliable as it should be…

Why not try the updates before put it out there ? (like the SnapMark feature)…

It’s the third update that I’ve been through with problems…

Sorry, But I had to tell something about it! :confused:

1 Like

I’ve had little time to forge lately, so always assume there’s an update. I just leave the lid up when I power on. The only time I’ve had a problem is when I forgot! So ignore what the wife says and leave the lid up…


LOL “…ignore what the wife says…”

Yeah, just did that now but no success! :confused:

And I have a job to post today… (very unlikely now) :frowning:

Hello - I have a 3 week old machine and it is getting stuck on focussing. Sometimes it works and other time I have to turn my machine off for 5 minutes. Turning it off for short time periods doesn’t work. I am very frustrated too. I use my machine daily and switching between cuts takes 10x longer then it should.

I’m sure you’re only being unlucky here! I’ve got mine for a bit of time now and gave me more pleasures than unhappiness! :blush:

I’m just a bit frustrated as It’s a problem everytine I’ve updated (knowing it has updated).

But hopefully remotelly they will be able to fix it! Which again! It’s a bit frustrating that I’m in the UK and they only have working hours in California! :smirk::pensive: so, a job that I would need to send today, I’m not seeing a light at the end of the tunnel to do it! :disappointed:


Mine’s stuck at focusing…

Last weekend when I was doing my printing(I have to go to another person’s house, so I save up my jobs and print all at once), the forge kept getting stuck on focusing. At first, I thought perhaps I was lifting the lid too soon, but ultimately, I would shut down and re-start. Finally, I got a purple button and I stopped. I felt maybe the machine needed a break, so I went home. I know we’ve printed since then, so I’m not sure what the issue was.

The Pink button is “safe/recovery” mode if I’m not wrong! But it happens when you turn the machine on pressing the “print” button! I’ve tried everything and still no success! :pensive:

I didn’t know you could turn the machine on using the print button. the machine was acting strangely. We were also having internet issues. I am of a mind that sometimes, stopping, resetting and restarting is the key, but I had to leave anyway, so I stopped. I’ll re-try again this weekend when I get some time.

Geez, I feel for all who have issues. My machine hasn’t given me any problems whatsoever. 18 months with the PRU and this one. Both calibrate in about 90 seconds without fail.
I can only imagine the frustration. I wish everyone had my experience.


Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.