SVG Files Importing Incorrectly

I have an issue when I upload SVG files to the UI: The GlowForge software decides to interpret the layers incorrectly. It interprets some lines as ‘cut’ which should be ‘engrave’, introduces new layers that were not in the original file, and also inserts some ‘engrave’ areas that were not even in the original file.

What’s stranger is that it only does this for random areas of the image, and I can’t figure out why.

I have tried collecting the original file into discrete layers to make it easier for the UI to interpret, but it still seems to grab random parts of the artwork and decide “this area should but cut, not engraved” and so on. I can’t see anything in the original file to distinguish those areas from the rest.

The original image is black and white, with red lines for cutting, if that helps at all. Does anyone have any advice? Attached is the most recent version of the file, for reference. Many thanks in advance!! LoweTiles_Small_Double_Set_Alt-groups.4-01|690x345

It sounds like your image is the issue.

SVG is a container. Think of it like a jar you can put pebbles in. Images come in vectors, we can call them black pebbles, or bitmaps, we can call white pebbles. Just like you can have white and black pebbles in the same jar, you can have images that have parts that are vectors and parts that are bitmaps. The GFUI will only engrave bitmaps, it can’t cut or score them.

The GFUI ignores your layers. Assign different colors to denote different steps. It looks like this is what you have done, but it also looks like your image may have parts that are masked or otherwise still there that the GFUI doesn’t handle the same way your graphics editor handles. It also sounds like you have a lot of different grayscale colors that the GFUI is interpreting as different steps.

I would convert the vector parts that you want to engrave to bitmap and then set the engrave settings to vary power for tiles. Keep the cuts as vectors.

Once you have the colors assigned you can set the steps in the GFUI, or somewhere on this forum you can find a guide to the defaults. I don’t personally use it so I don’t know where it is.


I think maybe something went wrong when you uploaded the file, I can’t download it to look at it.

I thought it could possibly be my connection but I reloaded the page and everything and it still looks like this.


I see what happened when I tried to upload! It should work now - give it a try?

1 Like

Currently everything in the SVG is a vector, only using two colors: black for engrave, red for cut. As previously stated, the GFUI does understand a lot of the SVG, and correctly interprets most of it to be engraved. However, some arbitrary lines and fills are interpreted as ‘cut’ and there seems to be no reason why. Prefect duplicates of the same image within the file are interpreted correctly, whereas others are not.

I will try to convert the engrave vectors to bitmap to see if that helps. However, the initial problem of randomly assigning ‘cut’ or ‘engrave’ to parts of the image file is still baffling.

The file you uploaded has no stroke or fill for the majority of the objects inside the circles. That tells the GF to ignore them. If that’s what you’re uploading, it’s no surprise.

You can’t define what gets cut or engraved (for vector objects) in the SVG file, you select that when you have it in the UI.

Layers have no effect, they are not recognized by the GF app.


I can’t open the file.
I use Illustrator, but in theory the file should open in either inkscape or illustrator or whatever.
I’m wondering if there’s something wrong with the way you saved it.

I can’t really advise any further than that since I’m not using Inkscape. Maybe there’s someone that can confirm the way it needs to be saved. Here’s the error message I’m getting.

The majority of the objects inside the circles are meant to be ignored - those are the white spaces. As stated above, the issue so far isn’t ignoring any parts of the image to engrave, but separating the image out into different objects and assigning some of those objects as ‘cut’ or ‘engrave’ erroneously.

I would also welcome advice on how to change individual parts of an object and change them to ‘cut’ or ‘engrave’ as my efforts so far have failed.

By color. That’s the only “grouping” the UI will recognize. Then, in the UI, you choose what to do for each “group”.

1 Like

How strange. Let me try reuploading the file both as an svg and an illustrator file: LoweTiles_Small_Double_Set_Alt-groups.4-01 (365.1 KB)

I downloaded the AI file and that made a big difference. Now I can also see the designs that are within the top three rows. Did you intentionally only use red for the top 3 rows though?

ok, getting back to the initial issue, i’ll come back shortly - looking at it now.

Hmm - no! In fact, when I look on my end, there should be red around everything. How strange. Let me check again on my end. Thank you for your help!

EDIT: The red layer is on the bottom (of this file at least) it should be on top. I’ve adjusted now! (368.6 KB)

A few notes:
Yeah I was just going to show you that lol I moved one of the groups over and saw the red lines underneath. I see what you did - moved the layers so the red is showing. But you don’t want duplicate lines there. You should remove one set of the lines.

I would reorganize the groups and try to clean that up a bit to make it easier to work with, personally.

There’s some really strange group with nothing in it, but usually it doesn’t allow a group without anything in it. Something weird is going on with that. I would delete that, too.

I definitely will delete the nothing group! There shouldn’t be a duplicate set of lines, so I’ll for sure get rid of those when I can identify them.

While I did all the designs in this file, it was originally assembled by a creative partner of mine and then shared with me. I might do better to just start from scratch after all this headache!

EDIT: I double-checked and in the .ai file there’s only one set of the red circles, so I don’t know why more than one set appears anywhere else?

There aren’t two sets of red lines.
If you hide the red circles, here’s what else is there.

So you need to delete the black circles. However, these are all one path

This is what you want it to look like when you hide the red circles.

I don’t know if that’s what’s impacting how it’s behaving or not, but you don’t want it to engrave and cut the same circle. Does that make sense?

Yes! I also found a similar solution while I was just tinkering here. The problem was, as you surmised, that there are two circle on top of one another as a compound path, that the GFUI was reading as a solid shape that would be engraved, like a thick ‘ring’ around the tile.

The solution, as you pointed out, was to eliminate the inner ‘empty’ ring and just shrink it down to be an empty, unfilled circle with an outline.

Conversely, one could take that set of layers and have them ‘scored’ on the GFUI, which amounts to the same thing! I think I might be ready to test this print out!

Thank you very much for your help.

EDIT: to be clear (incase I wasn’t) the objective is to cut the tiles out, but have a thin ‘border’ ring around the design on the tile (for the white tiles). Two ways to achieve this that should both make the GFUI happy.


I use scoring as much as possible. I’m crunched on time and engraving is SO slow. (However, with that said, I’m about to embark on a big engraving project for a Christmas gift, lol)

I use scoring a lot. Also, you can used a defocused score line. To do that, just tell the machine to use a focus height that is higher than your actual focus height. You can play around and adjust it a little.

1 Like

Wow trually, thank you so much for working through this with hector.lowe! It’s exchanges like this that make our forum such a great place for learning.

1 Like