The dreadful "Rendering your design"

Hey guys,

The past two days for the first time have I experienced not being able to open up my designs that I made last night. I have read about copying and pasting a lot which I did 8x on there. I have never had this issue and it’s a huge problem for my business. I have to make a new design in order to be able to print them. If I leave the page, I can’t get back into it. I know I can edit it in photoshop and make multiple copies as an svg. But it was sooo much easier just copying and pasting on the design itself lol.

Thank you to anyone that can help out!

Generally rendering issues on in your browser - have you tried a different one, or clearing the cache on your main one? If there was a blip in the WiFi and it got stuck that could clear it out.
If you can’t load any designs (:glowforge: provided ones as well) that it’s very likely that.
If it’s only your design that won’t load it may have become corrupted. You can try opening it in your graphics program and doing a save-as. See if that fixes it (after you’ve done the cache thing).


I have done all these things, but I am still getting ‘rendering your design’ on ONE (that I know of) design. I purchased the file from Design Bundles a couple days ago. I have opened it in AI and resaved it as save as. Anymore ideas?

It sounds like that one design has been corrupted or has something going on inside it.
If you’d like, send it to or to me in a DM, and we can see if it loads on a different system, and if not what the issue may be. I’d say post it here so anyone could help, but it’s a purchased design and likely against the terms you bought it under.

1 Like

I will send you the file. Thank you so much for your prompt reply. I think you may be correct about it being corrupt. I opened it making a new folder (I guess that’s the correct term), and it works when I run it from that folder. So weird.

Welp, I am going to ask you how to forward it to you? When I click the the three dots, it does not offer to forward it - it only offers to rename it, save a copy, or delete it. So, how can I forward it to you, please?

I am going to work. I will check for your reply tonight after work. Thank you so much!

If you click on my icon on the left, it’ll pop up a box that says “Message”:

You can then attach the file using the upload button:


Thank you so much. I am not having the issue anymore, but IF I happen to encounter it again, I will post here. TYSM!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.