Thwarted by "Filled shapes are open" error in a file with no fills (that I know of)

I’m trying to run the attached file, and I’m getting the “filled shapes are open” error. (As an aside, I wish the GFUI would give some indication which shapes are filled and open.) I’ve read many of the threads about this in this forum; the puzzling thing about this situation to me is that I don’t think I have any fills in this file at all. I’ve used Adobe Illustrator CC to click on each and every individual path in the file (there are a lot of them) and “join” all of them, one at a time.

It’s worth sharing that I’m brand-new at this (both Illustrator and GF) and maybe be making a colossal and super basic mistake. I’ll appreciate any wisdom somebody more experienced can share.

Seth112-131_sheet2_ai3

1 Like

I don’t see the file…you might want to Zip it before you upload it here. (The forum does strange things to them otherwise.)

Man, that was weird…why is it white? (I found it.)

1 Like

Okay, I just opened it without any trouble in the Glowforge interface.

At what point are you getting that error? (I’ve never seen a “Filled Shapes are Open” error…does that appear when you are rendering it for printing?)

1 Like

Thanks for taking a look! Sorry: the file isn’t comprised of white paths… they’re blue and orange… and just very, very thin (.001). :slight_smile: This is a sheet from a tight-tolerances craftsman kit for a 1/48th scale coal shed.

I see the error during the “verifying…” step after pushing print. The file uploads and appears just fine until then. I’m able to set power / speed levels, push print, get through the “verifying material” step… and get the error in the “verifying [I forget the exact word, but something to do with image / plan]” step. This step immediately precedes printing actually starting, as I’ve learned when I’ve gotten a few other files to print.

Huh! You might try increasing your stroke size…I generally use 0.2 pt. The thickness of the stroke has absolutely no impact on where the cut happens, but it might make it easier for the interface to pick up. It’s the only thing I can think of…everything else looks like it’s set up okay…the paths aren’t joined, but they don’t need to be for it to process.

1 Like

Thanks. I’ve tried with a .25 stroke, too, though… same result. The most puzzling thing to me is the reference in the error message to fills: there are literally none in the drawing that I can find. O_o

Well, I’m going to have to fire it up and try to run it…now you’ve got me curious…

1 Like

Nope…it’s printing right now. No funny messages. (12:07 am CST 09/16/2018)

Don’t know what’s causing it…probably need to have Support take a look at it. (How stable is your WiFi connection?)

1 Like

Oh, interesting. I wonder if it’s a settings thing in the GFUI. The WiFi connection’s pretty stable. Would you mind screen-shooting (or otherwise capturing) the settings you used for each of the layers when you successfully printed the page?

Thanks so much for your help!

Oh, that was easy…2/500 for the cuts and 1/500 for the scores. I was just seeing if it ran, not trying to actually cut it out of the cardboard…I knew those settings would just mark it without cutting anything.

3 Likes

Keep in mind SVG attachments on Discourse have their style sheets stripped out, so if there was something filled in the original, it may have been unfilled by the act of posting it here. A zipped version would be better for troubleshooting.

2 Likes

Oh, I can see the advise now… “Have you uploaded and then downloaded it?”

4 Likes

So posting the file here could be a way to solve the problem. If you get a “filled shapes are open” error post the file here, download back to your machine and then try it and maybe it will be fixed. Granted it would probably be better to determine how to fix the problem in your design software but if you have exhausted your options of finding the problem maybe that is a good work around.

1 Like

I believe:

  • Illustrator: set styling to “Presentation Attributes”
  • Inkscape: save as plain SVG

There are also online and downloadable cleaners that can optimize and scrub SVG files…

Ehh… I think the chances that Discourse mangling fixes a file are far lower than the chances of it causing problems.

If the only issue is that you have some filled paths, just do a “select all” and change the fill to None.

I didn’t see any filled shapes, but I saw lots of unconnected nodes and open paths – would that have triggered the error, maybe?

In Inkscape you can close all open paths in a single command usually. Boxes.py does all open line segments and was a pain to work with till I did that.

1 Like

One other thing…are you Exporting the SVG file or using Save As? (Save As causes fewer issues.)

Tutorial for how to correctly set up your SVG file here:

That should be an error you receive only if you attempting to engrave something. Are you trying to engrave or it is it only cuts?

1 Like

After taking a look at the information from your Glowforge, it appears you were trying to engrave lines.

When you upload a file to the Glowforge app, strokes (or outlines) become cuts, and fills (filled-in shapes) become engraves. The print failed here because these lines didn’t have any enclosed area to engrave. Thanks for letting us know about this.

To print successfully, you have a few options:

  1. You can keep your current design and choose to score it instead of engraving it
  2. You can edit your design by replacing the lines with thin rectangles that have a fill

If you need more help learning to design for your Glowforge, we have a tutorial that walks you through creating a design from scratch, with step by step pictures about how to create a shape to cut out using Inkscape, a free design program.

2 Likes