Tried to upload a 2.6 mb Image 5 Hours later

it says There is a file being uploaded already

“You can upload when this one is finished.”

So what is that?, I’m new but it’s just a picture, to their system?

Is it Mac Catalina compatible maybe, even though i use Safari for Mac, I wonder if it’s the operating system…

It sounds like something got stuck. I believe the quickie solution is to shut down the machine, and close that browser and clear the cache. I know some folks have also gotten it unstuck just by opening a different browser (program, not just a new tab in the same one)

1 Like

Yes, tried Opera, Safari, and same result…, still says uploading…tuned machine on and off, rebooted, etc…tried a different picture and it thinks some thing is still uploading.

I’m sorry to hear you ran into trouble. When I extracted some logs to investigate, I saw that you were able to upload and print a few designs since you started this thread. Could you please let me know if you’re still having trouble with this?

Thanks for checking! Yes I did! And it was this picture

it was only 2.6 mb but would not upload from my safari browser or opera browser, so I tried on my iPhone same thing, at least the iPhone would allow a size change so I went medium, actual would not work, large would not, when I went to medium it uploaded, I tried small and that did also, so on my end it had to do with the size of the file

1 Like

Thanks for sharing that file. I took a look at this file’s details and it looks like the original dimensions are 55 in by 36 in. I was able to upload at those dimensions without issue, but it did take about a minute and a half. I’m glad to hear this worked for you at smaller dimensions. If you continue to have trouble uploading larger file I suggest taking a look at our Wi-Fi troubleshooter.

I’m going to close this ticket. If you run into trouble again, please post a new topic here on the forum or email us at and we’ll be happy to help. Thank you!