Trying to use app from a different computer, asks me to set up the glowforge from scratch

How do I log into the app from a different computer than the one I normally use out by the glowforge?

After running back and forth from my computer where it’s comfortable to edit and my glowforge, troubleshooting unclear errors with my .svg, I decided to try to just upload from my main computer and keep doing it until I got the errors ironed out, then go out to the glowforge and try a print.

But when I log in from this computer, not the ancient laptop I normally use in the garage, it says “which of the following applies to you?” asking if I just received my glowforge, haven’t received it yet, etc. If I go to my account settings it shows my glowforge there, so it knows about it, but it won’t let me get at the app; it wants me to go through wifi setup and all that garbage, which I can’t do from this machine, a long way away from the glowforge.

How do I get past this and into the app to upload and process files from a different computer?

I found an old forum topic asking if one could use the app remotely, and the final answer was “yes, now you can do that!” but no explanation of how, and the topic is closed.

You simply log in using the same email and password as you use on your main pc or Mac.


Also, just make sure you are logged in on only one computer. It won’t let you be logged in on more than one.

1 Like

? I stay logged in on multiple machines all the time.


It will let you log in with more than one device but I’ve had issues with stability when I have done this.

It certainly used to crash if you tried logging in with two computers. The Tablet was not much good for fine settings etc but I could bring it to the Glowforge for direct control . However at that time I had to log out of the GFUI in the main computer.

If things have changed that I could have both up that I could do fine changes on the main computer but when many changes arranging the work on the crumb tray rather than running back and forth having the Tablet for that would be great.

1 Like

Okay… it doesn’t work at all for me. As I said, it sends me to the page you get if you’ve never set up your glowforge. That is, There is no way past this, except to set up the glowforge again, which doesn’t work from here, or make sense. As I also said, once I’m logged in, I can go to my Username menu, click Settings>Glowforge Printers and see my Glowforge in the list. So it’s not like it doesn’t actually know I have a glowforge. But when I click Home after that, it takes me back to, rather than So I can’t upload anything.

Really? Wow…I’ve had trouble with that, so just assumed that it couldn’t be done. I would actually love that if I could do it. Maybe I’ll try it again.

1 Like

This. Exactly. I do my main work on my desktop, but while I’m babysitting the GF in my studio, I could be working on stuff with my iPad. Dang.

I do it all the time, never had an issue with it.

EDIT: MacBook and Windoze machine, both running Chrome


UGH. It was a cookie or cache issue. Once I cleared glowforge cookies and cleared today’s cache, it worked. I guess now I’ll do that on my other browser and see if it works there too.

Though I still don’t see how, since I tried two different browsers, one of which I had never used to go to at all before, and the issue continued even if I switched users. However, I see from other problems that there is something VERY screwy in the way glowforge uses cookies.

All of which is to say, I think it’s a bug in the programming, not a browser-produced glitch. But I guess I have it solved.

Though the app still doesn’t seem to let me actually work on it (won’t highlight which items I’m entering settings for as I click them) while the printer is offline.

I wanted to make sure I had not missed something so I just logged on on the iPad, and a PC laptop. The iPad app is not ready for prime time but Chrome browser is so I am logged on 4 times on 3 devices right now and whichever one I press print on will start things rolling.

As someone eles said, clear your cashe if you continue to have problems.


Well, now you’ve got me curious. I have an iMac (desktop) and an iPad. I’ve got Chrome on both (I’ll have to make sure on the iPad)…I’m going to try it again.


I’ll be danged! I’m logged on to my iPad and my desktop, using Chrome. I’m glad I tried it again.


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!