Unable to upload .svg file from Illustrator

Hey guys!

I recently logged back into the Glowforge app and saw the new UI updates. In the past I was able to create a multi-layered file to pull out my cut lines and engrave lines.

I’m currently experiencing the issue of “Sorry, bitmaps can only be engraved”? when I try and select CUT. I’ve tried exporting this as a .svg, .png, .PDF, etc. I’ve also outlined the paths but nothing is working. I actually can’t even upload the .svg because it “won’t allow that file type.”

Is anyone else having this issue? Any solutions?

no issues here.

If you feel like posting the file, someone may be willing to take a look.

are you sure it’s not saying “Sorry, bitmaps can only be engraved”?
I ask, because I engrave vectors all the time.

1 Like

NarwinChristmasOrnament-CutLines.pdf (1.2 MB)

Ahh you are correct on the wording

It won’t even let me choose my .svg to upload either

opened in cc2018, and got a warning that this was created with the newer version of AI.
Did you just update? I seem to recall someone having an issue with the newest version.

in cc2018 this comes in as a stack of clipping groups, another thing the GF doesn’t like… but that may be a result of trying to open a “newer version” file.

pulling the shapes out the clipping groups, I notice that the shapes are filled compound shapes, and not stroked paths. While this should still allow cuts, it will give you double-cuts, one cut on the outside path of the shape, and one on the inside path. Did you use the “expand” command by any chance?

This might be closer to what you want… if this one won’t load/cut then there is a different issue.

I did convert to outlines because it wasn’t taking the first time, let me try again with just the paths! One sec

okay SO, it did allow me to choose cut this time by keeping them paths, however when I hit print it keeps scanning the bed and then says preparing your design but then just goes back to showing the bed and never allows me to start printing.

Try the file I posted. If it works, then you have a file issue. If it hangs up the same way, it’s likely a glowforge/cloud/WiFi issue

1 Like

Thanks for all your help here, @jbv. @lovesimpledesign, you may have experienced some trouble printing yesterday due to an issue on our end. That issue has been identified and resolved, so I’d like to know if you’re still having any trouble with this file? Let me know!

@vee I am having some trouble uploading files today :frowning:

The file you posted worked!! However that doesn’t solve why my glowforge app can’t open my .svg files.

I only work in Illustrator. Are you thinking it’s because the Glowforge app isn’t compatible with the latest CC version of Illustrator?

Fwiw, I’ve been uploading files from CC2019 with no problems. So it may be a file issue, but the 2019 files do work.

1 Like

@jbmanning5 How are you exporting from illustrator? Are you doing a “Save As” -> .svg?

i’ve been working w/CC2019 illustrator with no problem as well. Simple files, i literally copy/paste.

i’m the one weirdo here who almost never uses SVG. i make PDF files instead and have only once in the year i’ve had the machine had a problem getting a PDF into the GFUI.

I generally use the Export Option since I’m working on multiple artboards, and it’s easier for me that way. Export isn’t recommended though.

@vee responded above saying they had a hiccup on their end and wondering if it had been resolved - is that not the case for you at this time?

that was one thought, but not any more based on @shop and @jbmanning5 input above. Other thoughts were:
If the clipping masks that I saw when I opened your file in CC2018 do exist in your file (and weren’t a result of my using cc2018 to open a cc2019 file) then they could be at fault: the GF does not like clipping masks.
Otherwise, what do you use for your SVG save settings? When I am making stuff solely for the GF, I use Save As or Save Copy with the following settings:
(I seem to have good luck with these settings for use in both the GFUI and here on the forum)

I see you posted a PDF above… how about posting a SVG file that you can not upload?

PDF files are notorious for putting clipping masks around the border of the document. Since they aren’t actually clipping anything, they tend to be OK when the UI removes them.

I use basically the same settings that @jbv posted. I use 4 decimal places rather than 3 - but either works.

Either way, as mentioned above, Vee said they had a hiccup on their end… so curious as to if things cleared up for you.


Thanks for the additional details here.

The issue I mentioned on Friday would have accounted for the trouble you experienced printing your files, but I’m still looking into the uploading problems you’re reporting.

@lovesimpledesign, @scottmillersb (and anyone else in this thread experiencing trouble uploading recently), would you be willing to share a couple more examples of Illustrator .svg files you’re unable to upload. Individual files might fail to upload for a number of reasons, but the more recent examples we have, the easier it will be to determine a pattern of behavior.

Again, I’m so sorry for the trouble. If you’d rather not post files here on this thread, you can email them to support@glowforge.com. Please reference this thread if you do! I’ll follow up here as soon as I know more.

Thanks in advance!