Unresolved Issue Making me Seriously Question this Software Model

For months I have struggled with an issue that began sometime ago – my GF Pro which had worked beautifully for years suddenly started refusing to finish a job – ie the job actually did finish, but the software said it was cooling down – and never moving from that. When I exited back to the dashboard, everything looked fine. When I wen back to start a new job – the timer is going as if it is doing a job, but it isn’t doing any job and my GF is sitting there peacefully waiting for a new job. Here is a typical sequence:
12:49 – picked project, said “Rendering Artwork”, and then went thru the set up for the GF job to run.

12:51 – Said it was “Ready” and I clicked Print.

12:51 - Said “Magic Time” and I pressed the flashing white button

1:14 - Finished the job and said “Cooling Down”

1:16 - Still says “Cooling Down”

1:18 - Still says “Cooling Down”

1:20 - Still says “Cooling Down”, I exited the window back to the Dashboard and shut off my GF

1:21 - Turned on my GF , clicked on a project in the Dashboard, the working screen opens and the Printing Timer is counting down yet there is no job running

1:23 - I click “Cancel Print”

1:24 - Still canceling print so I exit the working window, exit the Glowforge site, turn off my GlowForge.

If I turn off my GF, exit out of not only GF in the browser but the browser itself and wait sufficiently long enough (15-20 minutes), I can usually start everything up again and do another job – with it finishing the exact same way. I worked with support for about 2 weeks to resolve this – trying multiple browsers, rebooting, verifying internet service, strong wifi service, etc. etc. etc. The last contact was that they were able to recreate the problem and were working on it. Not heard a word since. Meanwhile the problem continues. I’m not new to this – Purchased my GF as a “Founder” before it was even finished in development and have had quite a bit of success with it, but this is driving me crazy. Not sure where to go with this now…

Interesting that they’ve been able to recreate the issue. Did they specifically say which issue - being stuck in cooling down, or stuck cancelling, or both?

The stuck on canceling has been a long-term issue. I don’t remember when it first popped up, but quite some time ago.

With that being a known issue (under whatever conditions), it seems the stuck on cooling down issue that precedes stuck on cancelling would be the issue to deep-dive into.

A few things I think I’d try:

Connecting to a different wifi network (hotspot, for example).

Creating a new guest user account and seeing what happens there.

Running a print from a different device - ie tablet, mobile, different computer.


Ya, it is a common issue right now in their release. Happens frequently for me as well. It’s just in their backlog and hopefully resolved soon.

On the plus side, the newest release fixed all those annoying pass through issues where the design stopped showing. So in reply to this concern:

Think on the bright side that GF updates are resolving more problems then creating and we get new features.

1 Like

Also, I usually press it’s big button for a few seconds and get it off WiFi and then connect. Or I power it up without its printhead. Once it turns orange I then power it off and give it back it’s print head. Basically finding a way to kick it out of its state and throw a bigger error.


What is? Stuck in cooling down after the print (which is really just clearing the case and waiting for the final project picture), or stuck when you’ve canceled a print?


Having the same issue, job finishes but browser never catches up.

Sometimes a browser refresh fixes it, sometimes a restart of the GF’s fixes it.

I have two GF’s and I notice that they both fail at the same time.


Thank you – was beginning to think it was just me and the web connection/software was isolated to here. Not happy it is a known problem and still unresolved, but it is good to know I’m not alone in this.

How many times has the latest release of any software had a glitch? And you are back peddling reinstalling older versions before getting the repaired version? The difference with the cloud is it happens without needing to be involved.

1 Like

I’m sorry for the trouble and frustration while using the Glowforge App. Thank you for the detailed information you’ve shared with us. I see that you reached out to us via email about this as well. To avoid confusion, we try to keep things to a single ticket per issue, so I’ll close this forum post and follow up with you via email soon.