Uploading Error

Hello, I keep getting this message over and over trying to upload any designs. I’ve tried everything from a simple line to other svgs. I’ve refreshed, rebooted the GF. what is happening!

Screen Shot 2021-01-13 at 9.19.19 AM

Once you get it once you’re going to want to clear the cache on your browser - it seems to get stuck.
Are you still getting the error on a :glowforge: provided design?
If it’s only your own designs, what program are you using and are you saving or exporting?

I’m only getting it on my own svgs from adobe illustrator.
Some work just fine, then the next won’t.
And I’m saving them.

Ok, it just worked when I used the export method. Can you help me understand the difference between these?

1 Like

I don’t, but that is a known issue with Adobe. I’m guessing, based on using their .pdfs, that they put a bunch of formatting junk into the .svg file that the :glowforge: can’t read.

If you want to read more folks talking about it:

I believe when Adobe Saves as… an SVG, it preserves information within the SVG that helps with loading and editing the SVG in Illustrator in the future.

Where as Export as… isn’t going to worry about you editing the SVG in Illustrator in the future.

Practically, the difference is small. But you’ll find Export As… SVGs to be generally smaller, and likely have less junk in the file as @deirdrebeth explained.

Here’s an example, where I put the actual SVG code in the screenshot. The left is exported, the right is saved. The left file is about 40% smaller than the right.

Generally I’d recommend keeping your SVGs as clean as possible, and to that end, using Export instead of Save as, although I remember reading on these forums some folks swearing by Save as as being more reliable… so :man_shrugging:

The one other thing I’ve found that helps with the problem you described, is complexity in your shapes. e.g., if your shapes have a lot of control points, maybe more than necessary, that seems to slow the GF software way down. So for more complex paths I often simplify my shapes before exporting.


Thanks very much!

I really appreciate that, thank you!

Try copy/paste from Illustrator instead, that method bypasses the SVG weirdness. Use your keyboard copy/paste shortcuts straight from AI into the GF dashboard screen (the one with the all the thumbnails, not the bed)

I couldn’t get this to work. At least on OS X.
Tried both in Chrome + Safari.

From what I can tell, the GFUI doesn’t use the system clipboard at all, so I’d be surprised if this works.

It absolutely works, it was a tip from Dan. I and many other GF users have been doing this for years. Are you pasting into the screen with the settings and work area or the screen with all the thumbnails of your projects? It only works in the thumbnails screen.

Edit: for Windows users - ctrl+v pastes into the dashboard (thumbnails screen), ctrl+shift+v pastes into the GFUI (bed image screen)


Weird. I stand corrected. I got it working.

For some reason just Command-V doesn’t work for me.
Command-Shift-V works. (Paste and Match Style)
And selecting Paste in the Chrome Edit menu works fine (which should be the same thing Command-V does)

I suspect GFUI captures Command-C and Command-V within the work area, which is why it was suggested to paste in the screen with the settings.

I didn’t find where I pasted matters, but I have to either use Command-Shift-V or use the menu.

Thanks for the tip @ekla


Nice! I’ve never been able to paste into the GFUI screen itself but trying ctrl+shift+v, per your post, did work. Thanks :slight_smile:


Oh no, I’m sorry you’ve hit a snag.

There are some amazing suggestions from our other forum users in here, would you let us know if @jestelle and @deirdrebeth 's suggestions resolves the trouble?

If not, send us a copy of the file and we can investigate further!

Hi @knightweldingcanada. It’s been awhile since our last response, and we wanted to check in to see if the suggestions from @jestelle and @deirdrebeth 's helped answer your questions? Feel to let us know if you’re running into any continued trouble with designs or uploads, and we’ll be happy to help.

Recently, my wife was getting the same error while trying to upload SVG files created in Illustrator CC 2021 into the GFUI. I ran into this a while ago too, but couldn’t remember how I resolved it. I compared the SVG “Save as” settings on my wife’s laptop to those on my laptop. She was saving it as an SVG 1.1 and I was saving as an SVG 1.0 format. When we changed hers to SVG 1.0 she no longer got the error. Not sure what the deal was, but it fixed it for us and thought others could give it a shot as well. Couldn’t hurt, right? :slight_smile:


It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.