Weird things my glowforge does (restart, noises, calibrating)

I’ve got a short list of things my glowforge does that make me raise an eyebrow. I’ve never owned a laser cutter before, so it may be my lack of knowledge on some points, rather than any sign of a real problem.

The last couple of times I’ve turned on the unit, it will begin the startup sequence and after a short ways into it, the lights will go dim and it sounds like there’s a click from inside as if it’s completely restarting. The rest of the sequence after this is normal, and it’s been working fine, but it did not do this the first few days of use. I suppose this could be due to a software update issue, but what seems like a total shutdown and restart strikes me as odd.

I understand it needs to calibrate every time it’s turned on, but a few days ago I turned it on with the app open, and it reported the unit could not calibrate the head. I restarted the unit and got the message one more time, then a third start got past it. It did an automatic recalibration out of the blue today. It was successful, and I assume it’s programmed to do this when needed. But still I was like, “are you okay there?”

The last thing that gets my attention is a ticking noise after the startup sequence completes, and after a job is done. I think there are about five clicks in quick succession, then a pause, then it repeats. This happens a few times and then they stop. I assume it’s some internal system taking care of things.

Despite these huh moments, it’s worked flawlessly so far. So I may just be over-reacting, as it’s a new and expensive type of gizmo I’ve never owned before. Since it’s under warranty I’m not going to freak out about it.

And even though only time will tell me if the hardware holds up, I will say the software side of the experience has been amazingly good.


Everything you’re describing sounds pretty normal to me. I particularly like the little clicking noises it makes at the end :slight_smile:


Some of that restarting behavior may be the automatic downloading/installing of updates.


I like that, too. Besides the button giving a quick glow when it’s time to raise the lid, the clicking is an audible that lets me know all is well.


The Glowforge has a speaker in it but for some reason it is silent at the moment.

1 Like

Yeah, I wonder what the idea was behind the speaker?
Fire warning siren? There had better be a heads-up announcement before this thing talks to me.

“I’m sorry Dave, I can’t do that. It is forbidden to defeat the safety interlocks”


It’s currently hard coded in the firmware to play audio files for certain events like print completed.

But the files are empty, so nothing plays.

Current events: boot, cut_complete, cut_interrupted.


Just a quick thanks for doing what you are doing with this.


Thanks Scott!

1 Like

If only we could get some sound clips of Dan and drop them into the file system. :slight_smile:


Memory failure.
Wrong forum.

1 Like

Sounds like it’s time for a FEATURE REQUEST! :slight_smile:


This all sounds normal to me. I find that if I don’t panic from the calibration messages and let it finish what it needs to do at startup I have a smoother experience. I find that I leave it for about 3-5 minutes when I turn it on before I expect it to be ready. My SmartTV takes about 2 minutes to connect to WiFi, so I figure I need to give the GlowForge at least that much plus calibration time.

1 Like

I had an issue like this on Friday. It also was telling me my GF was to warm (I live in the arctic circle (Ok not quite there but it was around 8 degrees out and trying to snow). My house is set at 66 degrees via Nest, air vent near the GF is closed to keep the temp down.

over all I cooled the machine by opening the window I vent out of for a little bit and keeping the GF door open. That helped with the “I am to warm to work”.

I then fought with the I am not going to print because I want to calibrate but not able to. I figured the noises I hear were the machine trying to make sure it was in the home position. Moving the head and the gantry out a little bit (with it turned off). it was able to do its little move and figure out it was not home. It moved it self home and things worked.

My votes:

This does sound like the update behavior, but it depends on what you refer to as a “total shutdown” – for example, I’m reasonably sure the fans don’t power down during an update.

Naw… they need to use the “Wild EEEP!” sound that MacOS had years ago… that always cracked me up for some reason.

Regarding the speaker… ya know, speakers also serve as microphones… jus’ throwing that out there for the conspiracy theorists. :smiley:


Love it. :joy:


1 Like

Cameras and mics we have no control over!! :fearful:


Whenever I see the “reboot after power on” - which I think is firmware updates - it always blinks the lights and fans off briefly. If it’s not supposed to do that…