Why can't I upload this?

Devo.pdf (2.5 MB) So I just finished engraving several 8x10" rasterized drawings from illustrator, but when I try this little 3.5x3.5" using the same settings, it just uploads forever! No error message, no warnings about linked images or file size, it just loads and loads. What gives?

maybe try restarting your browser? I just tried on my end and it loaded in under a minute.

1 Like

Thanks for the response. I restarted both my browser, and my Mac. I also tried it as a jpeg and png from my iPad, but it never loaded. What configuration did you use to load it?

I am using google chrome and uploaded it as you had it saved above. from my pc

1 Like

DEVO.zip (1.0 MB)
I saved it as an .svg file. might be able to get that to work?

1 Like

I was having some problems earlier today. I have to hold down shift and hit refresh to do a force recache.

Not sure if yours is the same problem.

1 Like

I’ve been experiencing the same problem for the last couple of hours trying to upload the same size image. I have had no success even with format changes.


Thanks primal_healer,
I tried restarting everything again, tried Chrome, Firefox, and tried the svg you attached. No luck. Anything I send as straight up vector pdf from Illustrator seems to do ok. Just nothing raster. What’s so frustrating is that I’ve been uploading files with the exact same parameters, just MUCH bigger in size and complexity with no problem.

1 Like

@ Thumper369

Tried shift refresh (in Safari). No luck there either.

Nothing wrong with the file. Uploads in 3 seconds and “processes” in about another 5…

Chrome on Mac here.


1 Like

Thanks for that validation. Glad to know it’s not the design. Wish I knew why I STILL can’t upload it in any format. Exasperating!

If you’ve tried multiple browsers and even an iPad, I can’t begin to imagine what is going on. Support should be able to see something on their end.

1 Like

Try going into settings on your Mac, scroll down to safari and then clear history and web site data.

Tried that as well. Even went so far as to grant access to EVERYTHING from app.glowforge in settings for safari. But it’s interesting that I can’t upload the file through a new installation of Chrome and FireFox, neither of which had any history or cookie data. I’ve contacted glowforge support. Hopefully they’ll have something they can do on their end.

Just as a sanity check, I just tried it again to see if the servers were busy or something. Took a couple of extra seconds but that’s it.

1 Like

Don’t know what changed, but it’s finally letting me upload stuff again! Yay! Thanks to you all for all the help and recommendations.

1 Like

The glowforge gods decided you’d suffered enough.

1 Like

Mine finally uploaded about an hour ago.

I’m sorry you ran into trouble when trying to upload your artwork. It’s great to see that you’re now back to uploading designs as expected! I’m going to close this thread. If you run into trouble again, or have any questions, please post a new topic here on the forum or email us at support@glowforge.com and we’ll be happy to help.