Wifi offline

I’ve followed all of the steps to connect our Glowforge Pro to the internet. Yet, our Glowforge Pro will not connect to the Wi-Fi! I have called and left messages for (3) days to ask for help to connect to the Glowforge Pro to the wifi; and I’ve emailed Glowforge (3) days in a row. Customer support hasn’t returned my call for support. Nor are they helping me by email. All they continue to ask by email is: What step isn’t working to connect the Glowforge to the internet? What step isn’t working? I continue to state that I’ve followed all the steps to connect to the wifi, but no help!!

1 Like

Have you contacted your Wifi supplier? I was having all sorts of problems till I finally learned that they had turned my 2.4mhz Off! When turned back on the Glowforge worked instantly. Then I had to get and install a new system that would separate out the two MHz areas that was a massive issue as the old one was well buried.

Glowforge is pretty picky as it needs to get large chunks of data without interruption more than most circumstances, even though such times are only occasional.


I understand your frustration - dealing with Glowforge support can apparently be exasperating (I’ve been lucky enough not to have to contact them) - but they have resources none of us on the community board can access, like your machine’s logs. So folks here can try to help, but we’ll mostly be telling you to repeat the same old steps.

I’m honestly not saying this to tick you off, but the logical first question to ask is “what step isn’t working?” You say you’ve tried all the steps, but it will not connect. Clearly you got up to some point and then things went wrong. But you’re not telling us what that point was. This makes it much harder to help.

I spent years doing Internet technical support back in the 90’s. What I learned from that experience I usually summarize as “don’t tell them what didn’t happen, tell them what did happen”. In other words, “I can’t get online” is a lot less useful for troubleshooting than “An error message popped up that says my password is expired”. To expand on that, the structure I almost always use when I’m asking for help is “I did X, I expected Y, and I got Z.” For example:

“I followed the instructions at https://support.glowforge.com/hc/en-us/articles/1260807177450-Connect-Your-Glowforge-to-WiFi up to step 5 where it says ‘go to your Wi-Fi settings and select the Glowforge access point’. I went to my Wi-Fi settings, but there was no Glowforge access point listed. Here’s a screenshot: …”

And again, I expect there’s a 70% chance you’ll read this and get mad at me for being condescending. That was not my intention. I’m just trying to help. Maybe you just want to vent, and that’s ok too. But if you do want help from the community, you need to give us more than “I continue to state that I’ve followed all the steps”.


Yes, I contacted Charter Spectrum. Charter said it wasn’t a problem with the service… Eventually, I was able to get the Glowforge back online.

Thank you for your support,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.