Won’t work after cleaning

Hello! I recently cleaned my glowforge, by this I mean I cleaned all of the fans and mirrors. After doing so I kept getting the message “Head Not Found” Error. None of prongs in the head electronics are bent nor is anything un-plugged. I am not sure what to do at this point. I did have to loosen the hex bolt to get the belt back on but it moves from side to side just fine. When it starts it loves like normal for a bit the. Tried to go to the left side and makes a terrible noise, it will keep doing this and say scanning on the desktop app. I’m at loss.

With the machine off, try moving the head right under the camera and turn it on.


With the machine off try to move the head back and forth on the left side and check if you can see what is causing the issue :slightly_smiling_face:


I’ve tried to recalibrate it by putting the printer head and logo under the camera, it will go back to doing the same thing (it moved freely back and forth, the issue is it wants to keep going left even though it can’t( it literally goes all the way to the left and makes a terrible noise then goes back slightly then tries to go back to the left side and bounces back). :frowning_face:

Double check that your belt is on correctly after you cleaned and that there is not a twist. Open the front door, and with the honeycomb tray out watch as you move the printhead left and right. Anything catching?

1 Like

So no twist in the belt but it seems the far left wheel isn’t turning as smooth, this one does not have a bolt to tighten or loosen so I’m not sure how to fix the jerky-ness

It is possible that the pulley wheel on the left is cracked, but that doesn’t account for the “Head not Found” error or why it won’t home properly. Remove the printhead and inspect the wheels and rails and reattach, making sure the head sits securely on the rails.

1 Like

Okay everyone, so I took everything back apart and cleaned everything. I think I had the belt the wrong way behind the air assist fan, thank you so much for all of your help!


Oh no, I’m sorry to hear about the trouble @mmelleser.

It sounds like you received some excellent advice from our forum users and resolved the trouble!

I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at support@glowforge.com. We’re here to help!