Wrong file loaded in app.glowforge.com

I uploaded a file on app.glowforge.com, now every file I upload seems to be that same file. I cannot get any new file to upload and render in app.glowforge.com

I am using Safari on MacOS Monterey. I have tried Chrome as well, same results.

1 Like

That is certainly a problem I have not run into. What happens if you select “create a new blank design”, and then drag the file you want to load directly onto the bed?

1 Like

you’re using a beta MAC O/S that may be where your grief is, and your browser may not have been updated yet, can you boot from an older O/S and try it there?


1 Like

Good thought, I tried a different computer with the shared file and got the old file again. Very strange. It is this file, but there should be no text at the bottom. There always is when I look at the file in app.glowforge.com

Untitled 2.pdf (211.6 KB)

1 Like

it looks like you had stuff off to the side of the artboard, I think that may have messed with you…

here is a cleaned up file, you may need to re-do the text

SAVE THE DATE.svg.zip (31.8 KB)


Thanks. I’ll check it out and see what I messed up

1 Like

I’m so sorry to hear you are having issues with the file when uploading. I can see that you’ve also reached out via email and that our support team has contacted you there. From reviewing the file it looks like a footer is set up for that file which may be causing the issue. Please let us know how it goes.

From what I can tell, when you use Preview on a Mac to crop a PDF file, the PDF is not actually cropped, just your view of it.