Y-axis seems to be off and the laser movement may be faulty too

When I tried printing the Gift of Good Measure, the laser kept overlapping the cuts. The circles are never circular. It made the cuts, scores, and engravings as if it just took the drawing and blindly guessed the locations of each stroke.

I tried re-starting the machine to re-home the arm etc. I also cleaned the mirror and two lenses, as well as the camera lens. I figured perhaps the camera needed calibration. So I tried to troubleshoot the issue with the camera recalibration module that’s been discussed on the forum.

The print came out looking like this (see below). And I’d also like to point out that I had to manually terminated the print job because the laser box was physically hitting the front shield. (Notice that the top part of the draftboard had no prints? I think the machine thinks the board was lower than it really was and didn’t even know it was getting very close to the front shield plate already.) Any ideas on how to fix this issue?

Post a picture of the GoGM prints.

You have either belt tension, or motor issues. Here’s a post from support on how to check belt tension:


Yeah, that’s not good. There’s advice here somewhere on checking your belt tension – let me go find it, hang on…

1 Like

Ha, @eflyguy beat me to it. :slight_smile:


I’m so sorry to hear that you’ve hit this snag! As @eflyguy pointed out, I’d like to review the belts on your Glowforge.

Could you check the tension of your belts for me?

When pressing lightly on one side of the belt, the other side should not move.

Like this:

(You should see an animated image above)

Let me know if the belt is loose and I will follow up with your next steps.


Thank you all for the information and input.

I took a short video of me pushing on the belt. The belt didn’t seem loose. However, I did notice that whenever it tries to move the arm along the y-axis, the wheel on the right side alway somewhat falls off of the track - such that the arm is angled and not perfectly perpendicular to the track. I initially thought that’s normal. But now I’d like to know how to fix that…

sounds like one of the y axis motors is not driving. if you have the machine on can you rock the gantry or do both ends resist modest force in both directions?

Thank you for taking the time to review your units belt tension. I’d like to take a look at the behavior you are seeing as your Glowforge moves on the Y-Axis. Would it be possible to take a picture of the wheel that you are seeing fall of the track?

Once we can review the photo, and the logs from your Glowforge, we’ll follow up with the next best steps.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.