Yellow Light Frustration

I just received my Glowforge Thursday. Friday, I set it up and made a few basic items. Things were going well. I tried a larger project and in the middle, an error appeared that the project failed.

I turned the machine off. Then I restarted my computer and turned the machine back on. There were what I would consider normal start up sounds and the carriage moved, but not to center and it did not move again. That is when the yellow light came on. The image on the screen is the image taken at the start of the last project.

I turned the machine off again and immediately came here. I followed instructions for cleaning the lens, that didn’t help. I checked all of the connections, cleaned the mirror, wiped nearly everything with a lens wipe, unplugged it over night, I have cleaned connections, after I tried each suggestion, I turn it on, but there is no change.

I have tried centering the printhead under the camera before turning it on, holding the button until it turns teal then turning off/starting over… I have tried keeping the software closed, keeping it open, letting it sit in that mode for up to an hour… I even tried the using the trace option thinking it would force a new action. Each time, nothing new happens. I have tried with only the crumb tray, with no crumb tray - only a non-reflective surface, I have tried adjusting the light in the room, the temperature in the room it good, the vent runs slightly down with no major bends or turns… Am I missing something else? I am so frustrated and feel like I made a mistake. :sob:

Does your machine show “offline”? Can you double/triple check that the white cable is clicked securely into the printhead.


Thank you. The machine is connecting. It stays on focusing, centering, or homing - these do change randomly. I have left the software open when I turn it off and after a brief pause, it does change to offline, so I feel like that part is communicating. It just doesn’t move past that initial starting point. point.

I disconnected the cable again, checked the pins - and reconnected. When it clicks I give it a little wiggle just to be sure. Restarted, same result.

When you turn the machine on, what does it do?


Fan (and lights)comes on, After about 10 seconds there is a little revving sound followed by some clicking noises ending with a small “bump” sound. About 4 seconds later the printhead moves and the yellow light comes on. Right now the software is staying on centering. Nothing else happens from there no matter how long I wait.

1 Like

Can you check the other end of the white cable? Don’t disconnect, just inspect. Far left corner of the Glowforge.

1 Like

I tried to wiggle the cable. It feels secure and appears to be clipped in place. Still the same.

Well it looks like Glowforge support is going to need to address this. I assume you have emailed them already.

Final question, is the temperature in the room with your Glowforge within the stated operating environment temps?


Thank you, I really appreciate your time and efforts.

Temperature is good. We keep it between 68 and 70 degrees. I am in PA so the humidity isn’t bad either. I have even tried closing the blinds in the room to be sure it wasn’t too much light, lol no luck there either.

Thank you again.

That end of the white cable looks crooked to me.

Try seating it again.


Thank you. No luck, still the same thing.

I read over all the trouble shooting you have done. If you want to try something different then try moving the laser arm and print head towards the center of the machine when it is powered off. Leave it in the center and then power it on.

Also, have you had any times where you have left it connected to the window when it is off?

1 Like

Thank you for taking the time to read all of this. I tried your suggestion twice just to be sure I had it in the correct spot. It stayed in centering the first time, the second it wouldn’t move past focusing.

I set it up just this past Friday (9/2). I was able to make the measuring tool and a couple of small ornaments. I started a larger project and that is when the issue began. It was only a few hours from when I made the first item until it stopped working.

Thank you again.

It may take a few days to hear back from support but they can check the logs and see what the problem is. It could potentially just be the print head, but if not, the machine will likely need to be replaced.

1 Like

Also check the entire length of the ribbon cable visually and with your fingers looking for any worn or frayed spots.

Update: Support reached out. The machine is being replaced.

Thank you everyone for your suggestions. I am amazed at how willing everyone is to take the time to help. :face_holding_back_tears:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.