A little bug?

Not really, because of all the line segments inside the other line segments that are also needed. :stuck_out_tongue_winking_eye:

1 Like

When I load your design into the UI, it can only be moved as one piece if I don’t click anywhere else. If I click on blank space, then back on it, each segment now moves individually.

It’s not a copy/paste issue.

1 Like

There is a work around. If you do a copy from just above and left of where you want the paste to land and then move the original to elsewhere the paste will land on top of where the original was when you used the copy command and not where you moved it to. If you keep moving the new ones out of the way you can keep on pasting.

There are 4 other pieces in the design I loaded, all with similar construction. When first loaded, I can move any of them, including this one, around and position them simply by clicking on them once to select the whole piece, regardless of where else I have clicked in between.

As soon as it is copied and pasted, however, that ability is lost, and I have to either draw a selection box (if it’s working at the time) or hold shift and individually select all the little bits of it.

I’d upload all of them if I didn’t feel it would be coming too close to violating IP…

The copy/paste landing on top of each other isn’t what I’m reporting here, though.

Whelp, all I can say is I can’t move the one you uploaded as one once I have clicked anywhere. You might need to share your complete design directly with support.

Thank you for your browser information as well as the example SVG you provided in your first post. I’ve shared the SVG along with what you’ve described and logs I was able to locate. Our team will investigate and I’ll share an update as soon as possible.

While we’re looking into this, would you please let me know if updating to Chrome 80 leads to any improvement?

Heh. After upgrading, that piece comes in as separate segments to begin with, and I have to select it all in order to move it even before I copy and paste it, just like @eflyguy reported. The other pieces, even though they’re constructed the same way, select as a whole with one click both before and after I copy and paste them. I guess there’s just something about that one piece that’s goofy… :woman_shrugging:

I haven’t had an issue with the marquis select so far, but I’ve been stitching leather all day instead of lasering, so I haven’t spent a lot of time in the UI. I’ll let you know if that problem reoccurs, now that I’ve upgraded.

Thanks for your help!

1 Like

You may find the “Compound Path” feature (in Inkscape or Illustrator) does what you’re looking for.

I just did a quick test with the provided SVG:

  1. I opened the SVG
  2. I selected everything
  3. I made it one compound path
  4. Once uploaded, the app treated the compound path as a single object
  5. The same was true of the copy I made

I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic.

1 Like

Last night, around 7 to 9pm central, I ran into this issue again. I couldn’t marquis select and I also was having a really difficult time with click-selecting parts. I cleared my cache and restarted my browser to no avail.

Also, sheesh, it says my browser is out of date AGAIN. :roll_eyes:


1 Like

Browser updates can sometimes happen so frequently!

Thank you for that information including the time it happened. I’ve been able to locate logs from around that time yesterday and have shared them with the team.


After looking into this with our team, we’re wondering if you might be able to set up a design for us to take a closer look at. If possible, would you please do the following?

  • Upload one of the files you ran into this issue with in the Glowforge App
  • Create a copy and see if you’re able to reproduce the same app behavior
  • If you’re able to reproduce the behavior, please make no further changes
  • Copy the direct URL for your design, and send it to us at support@glowforge.com

Please let me know if you have any questions about the above steps.

1 Like

I’m having trouble connecting today, but will do this as soon as I get it working again!


Sent requested info, just wanted to add this, in case it’s relevant: At 8:12 pm central time I selected “set focus.” I went to try to place the focus but the machine went into “scanning” and then the entire browser crashed.

Still the same browser (WTH, auto-update???): whatismybrowser.com/w/ZXB25XX


I’ve received the design url via email. Thank you! I’ll also include notes about what you ran into yesterday when I provide the design URL to our team.

1 Like

I’m wondering if not being able to select could be related to the set focus tool. I just had it happen again (midnight central time) – I was trying to place a part as precisely as possible, so I moved it into position, then used Set Focus to improve my placement, and after the focus updated I was no longer able to click and select the part. I had to exit to the home screen and re-enter the project before I could select my part.


Thank you for that additional information. I’ve included it in the notes.

I wanted to let you know that the team is still investigating this. I’m afraid I don’t have any further details at this time, but we’ll keep digging into it on our end. Thank you again for your report that brought this to our attention.