About to lose my mind

I’m starting to wonder if I received a lemon or if I am just an idiot. Some days my glowforge works perfectly and other days I can’t get any work completed at all. It is hard enough to do work with 2 toddlers running around and this machine is stressing me to no end. I have spent 2 hours this morning trying to get it to stop scanning and centering- finally conquered that then it kept saying nothing in print area (I had already printed one thing and there is no reason it should have said that). After 45 minutes on that issue, I was assuming I fixed that we are centering AGAIN for the last 30 minutes. I don’t know what I’m doing wrong and I’m about to totally give up on it. If I wouldn’t have spent so much money on this thing I would have already given up.

I am sorry you are so frustrated! You seem to be having multiple issues, but most indicate a problem with wifi. If things work well, then don’t, it is almost certainly the connectivity issue. Try turning everything off - Glowforge, computer, router. Wait a few minutes then restart in the following order - modem.router, computer then Glowforge. Allow each to fully boot before the next is turned back on. Then reopen the app.


Thank you! I will do that now

1 Like

I was having an issue with mine this morning, and it turned out to be the wifi connection on the laptop I was using, and Glowforge was connected fine (but I didn’t realize it at the time). When I moved to my hard-wired desktop, things started working again.

In other words, the head wasn’t moving and the app said stuck in homing or whatever, but it had actually finished the whole calibration, I just couldn’t tell it until I went to the app on a different computer and saw it was sitting there ready.


Hopefully that fixed it for you. If not, here’s a useful list of things to check that can cause such errors:

  • New thing to try - remove all materials and restart GF: Glow forge stuck on scanning
  • Glowforge is Offline / Calibrating (support page)
  • Lens inserted correctly?
  • Turn the GF off, open the lid, turn it back on, and let it sit for a few minutes before closing the lid – if there’s a software update trying to download this will let it finish without interfering with the machine’s attempts to calibrate
  • Recent exchange? Make sure correct GF is selected in the GFUI
  • Look for any changes in the GF environment that might affect the wifi signal – one person had mounted a metal plate beside theirs, to attach their magnets to, and that was apparently enough to disrupt the wifi signal and throw the machine into eternal calibration…another piece of hardware could theoretically do the same (fan, printer, etc.).
  • Try changing the GF’s wifi channel – too many devices maybe trying to use the same one.
  • Sometimes cleaning the lenses seems to help – and also the Glowforge logo on the top of the print head, since the camera uses that for location purposes.
  • Sometimes the ambient lighting can affect the camera’s ability to focus – could be too bright, or not bright enough.
  • Check lid light cable clips Stuck on scanning during start up
  • Don’t cover up the logo on the top of the print head

I’m pretty sure I’m the magnet person :blush:–since I’ve mentioned it in other threads, too–but to clarify, I didn’t mount any extra metal plate to the unit–I had just placed a magnet on the black Al gantry/arm for the head, and apparently the next time the arm moved, the magnet slide against an existing metal part that is behind the head (left side) when it’s in home position…

1 Like

I’m assuming that it is a connectivity issue. After restarting everything it let me make 2 prints. Since then it has still been stuck in scanning/ centering mode. Going to hook up a new router tonight to see if that is the issue and go from there. Thanks for all the input and talking me off the ledge🤣

1 Like

Sometimes either moving the router closer, or strangely, farther away, can help improve the signal. Sometimes a signal booster can help. In all cases, you want to make sure you’re connected to the 2.4 GHz channel if you have a router that does automatic switching for you.


I sometimes get this error if I haven’t chosen a material - even if I’m then going to muck with the settings - just the act of clicking on a material makes it realize there’s something there

The other time is when the thing is ~just~ off the edge on one side, so it looks right, but is greyed out.

I just replaced the router and reconnected and still same issue. Glowforge emailed me back and told me to check all the connections for the wires inside machine and all are still in tact. I have worked on one sign for 6 + hours today and it’s still not 100% finished. So so frustrated

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.