Adobe SVG file won't upload when I uncheck "Responsive"

So I uploaded a file to glowforge and it looked great until I realized it had been scaled down upon import. For this particular project scale is everything, so I searched the forums and luckily found an answer rather quickly. So I went back into my Illustrator file and created a new SVG and unchecked the “Responsive” as recommended in the other post. Now glow forge won’t accept my file. It simply states “This design file has an error.”

So I’m clearly still doing something wrong, but I have yet to be able to figure it out myself.

My Settings:

My Error Message:

An example of an SVG that won’t load: …scratch that, here’s the Error Message this form gave me when I tried to upload a test SVG file:

And here’s a screenshot of what is in that test file - the artboard itself was set to the recommended 12x20:

Maybe this helps: Illustrator svg warps image on save - #4 by bwente

The posts near the bottom of the thread are the ones I think might help.


Through trial and error, it was discovered that this was the answer. Just posting this here in case anyone else runs across a similar issue.

“Preserve Illustrator Editing Capabilities” must also be unchecked.


Thank you for taking the time to try and help me find the answer.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.