Another Glowforge Offline intermittently

#1

This appears to be a common issue. Glowforge Offline.
Notes:
Glowforge works often! …when I can get it to connect… I have probably 15 hours of work run through it now.
But… If it disconnects, it’s a nightmare to get it back online.
Glowforge IS associated with the access point and has an IP address associated to it according to the AP.
Tried resetting the GF by pressing and holding the magic button till it turns green. Select it as an AP. Choose my AP (MakerSpace) and type the password. Error. Repeatedly. Tried again and again. Error.
Selected a different AP (we’re a school so there’s a bunch). Same problem.
Reselected the MakerSpace Wifi and it successfully connected.
Got called away - left it for 10 minutes while it was homing.
When I came back it’s back offline.

Here’s what I’ve tried:
Restarted Glowforge. Successful boot. Waited 5 minutes. Still offline.
Restarted AP wait 5 minutes. Still offline.
Restart Compy. Still offline.

Turn off GF. Press magic button while hitting the on switch. (I thought maybe it might be a hard reset thing?) Light turned purple!
Waited 5 minutes.
Turned it off and on again.
No connection.
Redid the setup. Error. Won’t connect to AP. - AP says it’s associated. ***note that I’m posting this while connected to “MakerSpace”.
As I type this, it appears that it has come back online since it just seemed to have come back to life. It’s centring. It’ll take 10 minutes to do this.
So. My question is this… Can I PLEASE get the network logs from my Glowforge to learn why the heck it’s not holding a good connection to my network? I’m connected currently to the AP with a Transmit Rate of 527Mbit from my laptop! I assure you that it’s not a problem with the wifi. There are three other devices connected to it currently.
If it’s a cheap antenna in the Glowforge, it’d be at least nice to know that! We all know that it’s an inexpensive device that does cool stuff! A cheap antenna, at least, would EXPLAIN this.

I’ve wiresharked the connection to my GF but there’s so little data passed so intermittently, that the data is not indicative at all of what the issue might be while it’s trying to connect.

I’d love to hear back from someone at GF who has network experience and can explain the issue along with the suggesting of troubleshooting steps. This way people with experience beyond the average muggle can troubleshoot the system, and not just the Glowforge.

#2

Since you said please… :wink: this link will give you instructions on how to access the machine logs, which includes connectivity.

1 Like
#3

Nice! I’ve seen many devices unable to connect due to what I think might be a solution to the problem.
Date and time.
All my log files have date and times set to EST.
I’ve seen many times devices that are unable to connect due to date and times being off.

So, I shut off the security on my AP and look! First try. Connected. Not ideal. But I can make MakerSpace Invisible. For the time being.

Two things. The Wifi cards driver in the GF needs an update to properly support more advanced security features (hopefully there are some), and secondly… Users should have the option to use the date and time from their computer’s clock while configuring if it’s not going to have an ethernet port to gain a connection that isn’t time reliant. The GF could even poll this info from the computer automatically with some clever coding.

Is there any way we can access the info about the network card to push down an update to it’s driver?
…and is there any way for me to change the time manually on my GF?

I’m almost hoping someone write back and tells me I’m way off base on my assumptions.

1 Like
#4

I’m glad you were able to get back online. Thanks for sharing your feedback and suggestions - I’ve passed them on to the team.

Once you’ve connected your Glowforge to your Wi-Fi network and started printing, you don’t need to go through the Wi-Fi setup steps again unless your network name or password changes, or you want to connect to a different network. Whenever it turns on, your Glowforge will automatically try to connect to the last SSID that was associated. If you see an “Offline” message after you’ve been connected and printing, your network is still broadcasting, and its credentials haven’t changed, there is most likely something impeding the connection.

Please note that your Glowforge is a legacy client device that uses 2.4GHz b/g/n to connect, so if connectivity issues are occurring, the same effects won’t necessarily be reflected in devices that use 5GHz. The Glowforge may still be more susceptible to environmental interference or band-crowding.

Additionally, the time and date used by your network will not affect the setup process, as the Glowforge does set date and time using ntp.org. That’s why your Glowforge will need access to the following on port 123 using UDP for setup to be successful:

One more note: you don’t need to hold the button on top of your Glowforge down when you turn it on. If you do this, Wi-Fi setup will not be successful.

If you’d like to share the logs from your Glowforge, you can email them to support@glowforge.com and I’ll be glad to take a closer look.

2 Likes
#5

This is exactly what I was looking for, my Glow Forge this week has lost connection twice.

This has never happened before, has to be something on the Glow Forge side . Please advise. ?

Today is March 13 and it went offline about a few hours ago.
I was able to get it back online but it took several attempts, no fun.

#6

You need to start your own thread which opens a new support ticket. They only address one persons problems per thread/ticket.

#7

Knocking on wood… so far 2 weeks I’ve not had offline issue–changing channels for my network helped once, just threatening to send a problem “ticket” got me on-line again. Agree that the GF needs a more robust wifi antenna since interference outside of our own control is only increasing (as well as support of 2.4gHz by network/cable providers–all focus on 5gHz now).

#8

We keep a very controlled environment , so because of this I do not think it is outside forces causing a disconnect.

If that was the case , I would not be able to get back on line by just restarting the unit several times . keep in mind that Its been over a year now that I have this glowforge and never had this issue. this is most likely firmware related.

#9

Well, as long as you can control your neighbor’s devices, or are miles away from anyone else that could have a device that could cause interference, I’m impressed. But indeed I agree it’s ultimately either GF F/W or H/W robustness issue. I also went for over a year before I starting getting offline issues–so far intermittent. But the system also relies on the cloud–my TRACE had 17 hops, many timing out, so can be an issue in another state or country even (since my trace was Seattle-Amsterdam-California…) that it can break down.

1 Like
#10

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.

closed #11