Bitmap option

Is there a way to turn off the bitmap options? I was doing fantastic pictures until the new update was rolled out. Since then my way of prepping to print them has went to nothing. fish-horz This is before after bitmap and this is after.

Can you elaborate on what you’re referring to as “bitmap options?” I’m confused by your photos…did the fish turn into a woman with a wolf?


The pictures are to show how things looked before the bitmap option was introduced (fish) and after (wolf an maiden). I had a process that worked an now they look like the wolf and maiden. Are you seeing the bitmap option when you try to engrave a picture???

There is no “bitmap” option. Engrave settings have not changed.


A screenshot of what you are seeing would be helpful.

I’ve never seen a bitmap option. Like @eflyguy said, a screen shot would be helpful!


Are you referring to the Bitmap option under the engrave settings when working with the manual engrave settings? You’re right, it has changed. I can’t remember what the other options were… looks like it is still there but under Gray scale> Convert to Dots/ Convert to Patterns / Vary Power. If I understand things correctly, you would want to select “Convert to Dots” as that is what a bitmap is … hope this helps

If I am wrong, someone please set me straight!! :slight_smile:

Greyscale options did not change either. These were always the three options:

1 Like

I’m sorry you ran into trouble with your engraving results. In order to look into this for you, could you please send me a screenshot of what you see in the Glowforge app when this happens? Make sure to include the rulers in your screenshot and show as much of the bed as possible.

To take a screenshot:

  • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.

  • Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

Are the examples of the fish and the person with the wolf printed on different materials? Also, are you using manual settings or one of the default engraving options?

Thanks Ivan for responding and the others also. Let me start by saying I am super confused and this is after I have had my machine for over a year and thought I was very proficient at pictures. I seem to think part of my problem is with the update since that is when the problem started. I us strictly “svg” files for my pictures. Now it seems like the system has lots of lag. I can try to position my picture and it won’t move or just goes somewhere else on screen. When I try to set my engrave settings I get the bitmap option and other times not. This doesn’t matter if it’s imported or I use a file I used before. Eflyguy thanks for the screen shot but them have not been something I have seen for a while I remember them but not seen for awhile. I also could not get it to let me set focus today. I am hoping this is enough to get me some help. My only other thought is do I need to reset everything because of the updates?
TIA Loren

Regarding the trouble with lag in the app, I apologize for any inconvenience. It may help to clear your cache and cookies when this happens. You can find instructions here: Chrome, Firefox, Safari, Edge.

When you refer to the “bitmap option”, I’m not sure what that’s in reference to. So we can help, could you please provide a screenshot of the option you’re referring to next time you see it? This will help us better understand the circumstances around the trouble you’re reporting so we can get to the bottom of it.

I extracted the logs from your Glowforge to look at set focus attempts prior the time of your report, and I wasn’t able to find any that failed. Could you please let me know what happens when you try to use set focus?

Very curious to see screenshot of the “bitmap option”, as no such option has been added and engrave options were not changed with the update…

Sorry for not being able to get back sooner. Here is what I am talking about. convert not to anything convert to dots . Before the update I could always do my pictures like in the 1st. pic .Now I have to use the second picture. I could do wonderful pictures before but now I have to figure it all over.

Oh, I think I understand what you are talking about…

It has to do with the type of pictures you are sending to be engraved…

Your first picture is a vector image…it does not have all of the options that the bitmap (photo or raster) image does. It is created using closed drawing paths with a fill color.

The second image consists of pixels…it’s a raster image (or bitmap).

You get more options with the second image, because the Photo Engrave settings automatically use “dithering” on images that have multiple shades of gray in them. Since the laser can only burn one color, it dithers the image to fool the eye into thinking there are different shades of gray for the photo…like old printed newspapers used to do. The more widely spaced the dots are, the lighter the gray color appears to the eye.

It’s always been that way. Any vector image with a fill color can only engrave in one “color”…solid black. So it doesn’t give you the options for dithering that a photo (raster) engrave does.

It’s pretty easy for photos though, just use one of the Photo Engrave default settings for your raster (bitmap) images. (And the software will default to that automatically if you save an SVG file that has a bitmap in it. SVG files can contain either bitmap images, or vector images or both. The software defaults to the correct kind of engraving for each part.)

If you need more of an explanation, there’s a short tutorial here that explains what’s going on:


I prepare my pictures by using PSP to grayscale then run a script I purchased. I then go to inkscape an turn it into a svg. Then send to the forge an I have not run into the bitmap option till lately.

If the image consists of pixels, (after whatever you’ve done to it), you’re going to get the Photo Engrave options by default. Did you read through the tutorial I linked? It does help to explain it. :slightly_smiling_face:

(Or you can just click the BACK arrow at the top of the popout and choose SD Graphic for the engrave setting. Don’t know how it will turn out.)

1 Like

Yes I read the tutorial and tried using the Draft Photo setting. My picture came out with a lot of dots an not close to the quality I have done before update.

I’m sorry about the ongoing trouble. It’s great to see that you’ve been receiving some excellent advice and information from our other community members. Would you be willing to share a copy of the specific file you’re seeing this app behavior with? I’d be happy to take a closer look and advise on next steps.

If you’d prefer to share the design privately, you can email to my attention at

This is happening with any type of picture. Seems not to want to upload a svg file.
exit of adam an eve
Had to send in email.

Thank you for sending us an example file. I’ve responded to you with next steps via email, so I’m going to close this thread while we continue troubleshooting there.