Black lid cable - spare part - help me please

Goodmorning everyone. Unfortunately my glowforge has this error: “The camera didn’t take a picture”.

I’ve already tried to follow these guides but nothing has changed:



when I turn on the glowforge the head does not move and immediately notices the error: The camera didn’t take a picture.

I send you the photos of the connectors.

i think that black lid cable is the problem.

I tried to shop it on glowforge’s shop, but i live in italy and the shipping cost is about $119.60.
it’s really absurd!!!

is there anyone in europe who might have the replacement cable? Do you have any suggestions?
Thank you all for your availability

1 Like

Hi @info8. I’m sorry to hear that your Glowforge is having trouble with the camera not taking a picture. I saw you had opened an email support request that I just replied to earlier. I’ll go ahead and close this thread so we can continue any troubleshooting through that email thread. This will help us avoid any confusion, or delays with responses. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.