Can NOT connect to WiFi (AGAIN)

Hello, I am extremely frustrated with the unit unable to connect to my WiFi…
This always happens I need to set it up on a new connection… HOURS and HOURS of trying just doesn’t resolve anything.

Here is my current problem:

I tried it all: 2.4Ghz (disabled 5G), Different computers, operating systems, phones, browsers and even wifi repeaters, security settings, reset of all equipment, moved all equipment close together…

My machine booted up in :purple_circle: ← Purple mode (OS Reset)
This happens when you keep holding the start button in while switching on the machine.
I presume something was stuck in my button and it was jammed in, so my machine booted up into Purple Mode…
Regardless, I pressed the button quite hard (maybe clearing out the jammed situation) booted into purple mode willingly… and after a restart (without holding the start button), it finally turned green: :green_circle: like it used to.

I hear your frustration and I sympathize.
I know you are sure the password is correct, however, just for giggles try entering it again (not pasting it) and turn on ‘show password’ while you do it. It may just be a simple keying error you’ve overlooked.


and I second this!

I have found that if I type too fast in some websites, my pw gets garbled some how.

1 Like

Sorry you are having such a rough time. Your cat is really cute.

If you disable wifi and use your phone as a hotspot, will it connect?

1 Like

when I type the wrong password in, the connection stops in 1 second with a failure, when I type in the correct password, it takes time to do some process and eventually give me an error, besides that i have tried about 300/400 times so far, I am sure that I managed to spell the password correctly at least once during those attempts :wink:


It connects in the sense that the G.F. starts using the wifi of my phone,.

But it still gives me an error at the end.

Thanks, I appreciate the thought, but it takes a lot for me to make a video, yet alone an enraged one like that:
The first 100 attempts I am calm, after I tried every possible variation I can think of and spent another 100 or so attempts, that’s when things start to boil up. I keep going until I am about to go insane, and at that point, I’ll make an angry rant video.

So a simple thing like “try typing in the password correctly” has been extensively studied and repeated on many… MANY attempts. I wish I was typing the wrong password, but it’s impossible, especially since I can check my router when a successful connection was made, and what devices are connected, GlowForge connects, it just does not register the connections as successful.

Just to be 100% clear:

Glowforge DOES connect to my WiFi, it just does not register and gives me an error.

To test this I opened the Guest Network renamed it to VodafoneGlowForge:

and when it connects I get a Notification on my app that 1 device (GlowForge) is using that Guest Connection.

I presume this means that there is no problem actually connecting the GlowForge Machine to my WiFi router, but rather something to do with their servers acknowledging the connection.

So yeah, a question to GlowForge: What Gives?
I know it’s beyond this WiFi request, but if they’d at least added a USB or Ethernet port, this would have been so much easier!

1 Like

Glowforge staff does not read these forums.

1 Like

Sure they Do.
I sent them an email with this thread, asking to resolve my issue.
I’ve seen plenty of staff replies, and who closes these threads?
And even if this does not reach GF, I still have the right to vent at them for their planned limitations, because it is because of those planned limitations that these kinds of problems exist.

They did read the forum in the past, but that has changed. That is why the category is now called Community Support. This was stated in a Glowforge Announcement recently. Of course you can vent here, but Glowforge staff isn’t seeing it.


Well, thanks for the tip.
I guess the Giant has abandoned the deck, and the captain resides in his cabin.

No, they never did.

They use a ticketing system (ZenDesk to the best of my understanding) - new posts in what was “Problems and Support” would open a new ticket. Any posts in the threads here would be appended to the ticket. Any reply they submitted thru that system would show up as a “post” here.

… but they never “browsed” the forum.

… and that connection to their support system was disconnected a few weeks ago.

The only exceptions are Dan (CEO) and Rita (head of support). They would drop in once in a while.


I’m a bit confused by the purple light. I thought it was supposed to be “teal” during WiFi setup. I’m not sure, since I only ever set up the WiFi on mine once, in 2017, and it has stayed working ever since. Not gloating or minimizing your frustration here, just that connection issues are very situational. I used to have an ink jet printer that simply wouldn’t connect to my WiFi at all. I have literally hundreds of WiFi devices in my house and it was just that one printer and my router that refused to talk to each other. Then one day I updated the firmware on my router and it connected perfectly. There must have been some tiny protocol incompatibility.

Anyway, back to the light: I think purple means it’s in some kind of diagnostic mode (I think to allow you to download the logs?), but it’s not a good sign for getting online.


So your intent is to connect your Glowforge to some kind of guest wifi? Is it possible that there are some kind of port/security limitations on that wifi network that might screw up the GF’s ability to talk to home?

I don’t know what ports the GF needs, but with all the problems you have been having I would next try to connect it to a wifi access point that didn’t have a lot of security restrictions.

You are absolutely right, it seems my GlowForge was indeed stuck in some diagnostic mode, I just read somewhere that Purple meant WiFi not Connected, but maybe I misread.

I turned the GF off,
kept holding the button and turned the unit on
It became purple again as it did before
I then turned it off and on again
it stopped booting in purple mode.

Then the normal steps to connect to WiFi
After GF initialized, I held the button for 10 seconds which turned teal
entered the setup, and it finally connected.

Your comment helped me try something new, and get results!
And I thought I really had it this time.


Thanks for your suggestion, My router has no restrictions,
If you want the logic of why I made a guest network:
It was for testing purposes.
The new “Guest WiFi” will have zero devices connected to it, so if I connect the GF to it, it will be the only one device connected, and that way I’ll deduce whether it was connecting to the router at all, or if the problem was elsewhere.

Either way, it turned out that my GF was in some kind of diagnostic mode.
And thanks to everyone who contributed to helping me solve the ISSUE.

p.s. sorry for being cranky in some of my messages.


Glad you got it sorted! Reading some other threads, it looks like the difference is holding the button while turning it on versus after it starts up.

If they ever design a new model, I really hope it has a screen. And of course a wired network port.


I am having a similar issue with one of my units,
how did you get it “out” of diagnostic mode?

My issue is after 10 attempts I see it in my wifi ‘Glowforge xxx-xxx’ but when I try and connect it fails, then disappears, tried every trick I know, including shutting down my home wifi completely and trying to just get it connected to my phone, no joy all around.


To get INTO Diagnostic Mode (Edit: OS Reset Mode) you have to:

KEEP HOLDING the Start button
While Holding, turn ON the [ON/OFF] power switch at the back.

So I did that… :purple_circle:

Then turned the machine OFF
Waited some minutes
Turned it ON again
…it stopped going into Diagnostic Mode.
Tada: :green_circle:

:thinking: Come to think about it…
My start button could have been stuck.
So when I booted up it was simply pressed in…

But I can’t tell for sure, as the error did not replicate itself again.