Can't upload anything

I just got my Glowforge and I’m trying to learn how to use it. I was able to upload one image once but now I can’t upload anything it will just sit there and say uploading for hours, no matter what time of day or anything. It never uploads, I then try a smaller size image and it says it’s already uploading an image or it does the same thing and just sits there. It’s the same image I uploaded once just altered a bit and that one uploaded in about a min. I can upload even bigger images to email and on to other sites with no problem. I contacted support who said it’s my problem even though it’s only Glowforge site that I can’t do anything on. Anyone else have this problem I don’t know what to do??? I don’t want a $5000 machine that I can’t even do anything with. HELP!!

A couple of things to try… Clear cache and cookies for the glowforge site… Or try another browser entirely and see if the problem persists.


Welcome. I am sorry you are starting off with a frustrating problem. Which browser are you using? Many people have had success with Chrome. Also, what kind of files are you trying to upload - svg, pdf? Finally, you might try dragging the file directly onto the Glowforge bed rather than upoading it into the library. Finally, you might share one of the files you are trying to upload. Simply drag the file and drop into a reply bubble here on the forum.

I have tried both, nothing different.

FYI - when you post in P&S it opens a ticket with support, which from your comment you’ve already done. They’re just going to come in here and close this one eventually but we can try and assist in the meantime. They have a bunch of responses to issues like these, but none of them are “not my problem” so what did they have you try, what did you do, and what were the results?

What you’re describing seems to happen when the :glowforge: gets stuck on one file, and then you need to log out of the GFUI, clear your cache, and then reload, and then relog-in in order to get it to stop trying to chew on the prior art.

I am using Chrome I have also tried using Microsoft edge with the same result. I can upload svg. but the one I’m having problems with is the jpeg. Even if I drag and drop it’s the same uploading forever problem. I uploaded the same photo the first time with no issues but now it won’t do it. I can’t upload any jpeg

Ah, that clears things up. Likely there is something in your .jpg that is having an issue. If you post it here someone can assist. You’ll still need to do the browser clear to wipe the :glowforge:'s cache

1 Like

Your experience is not typical.

I can’t offer any suggestions as to what else to try. The user interface is independent of the machine (it doesn’t even need to be turned on to access.) So it’s something between your browser/computer and the Glowforge servers.

I haven’t “cleared browser cache” in 15 years or more.

1 Like

Can you drag your jpeg and drop into the forum and someone here will try to upload it. As noted by @eflyguy the machine doesn’t even have to be on for a jpeg to be uploaded or dragged onto the Glowforge bed and processed.

Great, they told me
-do a speedtest
-.95mbps may be detrimental (even though I have no problem uploading to any other webcite or email)
-open a hotspot
-try a different network (neither I can do since I don’t have cell signal and it’s my only network, how can it be my network if I only have trouble with the glowforge site)
-ISP maybe places a limit on uploads (it doesn’t)
-my router firmware is out of date (it’s not it’s 2 weeks old and updated)
-then they have misunderstood me (I think) and said that since I can download anywhere else the problem is my home network ( I can download/upload to any other website etc with no problems, only have problems with the glowforge site)

I did log out and log back in and cleared the cache and it didn’t do anything. I have been trying all sorts of things for days now.

Can you go to and post the results?

support asked for this photo and said they could upload it in 15 secs. I tried 5 other photos and they all did the same thing,

I dragged this onto the Glowforge bed (my Glowforge is not turned on) and it processed quickly. Sorry, I wish it was the picture but it isn’t. Do you think you might have a firewall, ad blocker, or some other mystical/magical thing that could be the problem. I wish I could help.

1 Like

speedtest results
download 8.83
upload .80

if I can upload the photo here and other places then wouldn’t it be the glowforge site??

How do I fix a problem between the servers and my computer? I did it once and I can bring in svg.'s with no problem. I don’t get it

mystical/magical thing for sure since I don’t know why else it’s not working lol.
I don’t know what else it could be but I think I’ll try a different computer and see what happens.

Have you tried importing the jpeg file into your graphics program - like Inkscape, saving as an SVG and then uploading. I know this seems ridiculous, but if you can upload an SVG maybe you can upload an SVG that has an embedded jpeg.

1 Like

Can’t help you with how to fix it, sorry, but I can understand how such a low speed could cause issues.

They may need to change software to support such low speed connections.

I’ll have to try that and see if it makes a difference or not.

I tried turning it into a svg and it still just sits there saying its uploading and nothing even if I drag and drop the svg same thing, I just uploaded a non picture svg and it took like 5 secs. strange

Guess nobody ever should then.

Believe it or not… People in the real world do sometimes need to kill a cookie or two and clear cache to help with a problematic site. So it’s always a good step to rule it out. Maybe it’s just the programmer in me… I will run through a lot of steps that I shouldn’t HAVE to do, because I know they shouldn’t make a difference, just in order to rule them out. Rule things out in order to shorten the list of things that it MIGHT be.

1 Like