Can't upload files for printing

I’ve spent almost 3 hours trying to get a file to upload.

At first I was afraid the file was too big/complex (at 25mb) so I simplified it down to under 10 mb.

It still would just say “uploading” and never finish and add to my files. So I cut the file into 4 pieces. Each one 2mb. Still, it get hung up on uploading, but if I refresh after 5-10 minutes it will show up in my files. But I haven’t been able to upload part 4 - despite it being identical to the first 3 - just with the parts in a different position on the bed.

So, I finally got 1 part uploaded, and I go to print it… and the print fails - now showing me that 2 parts are outside of the print area. The print area is no longer 11x19.5 but 11x18.5

The issue is that I’m printing medallions that are double sided - so everything must be in the exact same spot for the first size and 2nd size- which means they all need to be ordered in illustrator, as the glow forge app doesn’t have the layout precision needed.

Some suggestions:

  1. Lose a column of tokens in your original design. Engrave size for the bed is smaller than cutting size - by about an inch or so. So eighteen inches wide sounds about right. Give yourself some leeway.

  2. You don’t need a 25 MB file, or even a 2 MB file. Without seeing the file you are working with, it’s hard to make suggestions, but you might be able to reduce the PPI on the raster images and come out ahead. You should be able to engrave a full bed size image. (Don’t use the High Def Engrave setting either.)

  3. There is a tutorial that tells how to do double sided engraving here. If you have already read it, that’s fine, but adapting what’s in it to a full sheet of tokens might require rasterizing all of the individual images into two separate large bitmaps. (If you want to post your file, I can take a look at it and see if it’s feasible. I don’t want to type up all the steps if it isn’t going to work in your case.)


And to add one little note to what @Julessaid, watch your colors. Make sure the reds are the same value red, blues are the same blue, etc so the GF groups them properly.

Also watch the number of nodes, and make sure you don’t have lines on top of lines.

Those are my normal upload or cut time killers


I’ve tried at many different versions now with no luck. This is beyond frustrating - especially since there isn’t even an upload progress bar - but after 20 minutes trying to upload a file that’s just a few mb, I have to guess it’s not happening.

I’ve tried Full vector front & Back 1 file
Full Vector front and back 2 files
I’ve tried Vector + raster as 1 file
Vector + raster as 2 files
I’ve tried Vector as 3 files (side 1 graphic, side 2 graphic, cut/score)

File is here:

all the nodes on those grunge fonts are probably killing you. if you try rasterizing that layer to whatever DPI you’re going to engrave at, i suspect it will fix most of your problems.

here it is with that layer rasterized at 340dpi.

Hogtowner V3.pdf (7.8 MB)


Yea. I have a rasterized version too… that I also couldn’t upload successfully. But I’ll try yours for good measure.

Figured I’d just share the master.

Definitely the grunge fonts – bazillions of nodes!


Holy nodes Batamn! That’s likely the problem.


I hope you got this resolved already. If not, I got this one to process fine. I didn’t try copy/past to make it one full sheet as I didn’t want to press my luck, but it might still work. (I broke the file in half, converted the engraves to bitmaps and combined the vector layers. )


Thanks. I got sick of wasting time with it for one day - tomorrow I’m going to change the font and see if it works.

1 Like

Been there done that more times than I care to admit. :confused: The grunge font does cause a lot of problems as the nodes on them are generally pretty sloppy so it might help to change it out. Keep in mind though, if you leave all the engraving layers as vectors there’s a good chance you’ll have the “random line” issue pop up and there’s really no way to predict if/when it’s going to happen. (The GUI can mis-interpret nodes that are touching as open paths and the likelihood goes way up with super node heavy graphics like this.) Good luck and let us know if it works out.

1 Like

Yea - I’m not super optimistic considering I couldn’t even get both sides of the raster to upload. We’ll see

Thanks for the tips, everyone. @BluBot can you let us know if you’re still having trouble?

I ended up doing all the type and was able to upload it.

I get that the nodes were an issue, but that doesn’t explain why I couldn’t upload raster versions either… Oh well, seems to be okay now.

When I rasterized the whole file it was about 58 MB, PDF uploads max out at 30 MB. That’s why my half sheet version at 27MB load and processed fine.


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!