Connected to wifi, but won't connect to the server

My Glowforge does not appear to be connecting to the server. I have confirmed that it is connected to the wifi router, and that the router is connected to the internet, however when I open the app page, it shows me as off line. I was working for me a couple of days ago, but has not been able to connect today. I tried a full reboot (holding down the print button until it went green and restarting, etc), I am able to ping the Glowforge IP from my laptop. and have tried accessing the app from different browsers, but it is still showing as offline. Any advice?

Here’s a good list of troubleshooting steps (also check the support site, of course):

Have you tried searching for “Offline” in the section? There are a lot of things to try… and see that @geek2nurse just provided some while I was typing! Good luck, I’ve been there too–had to change the “channel” for my network to 9 & then 11 and I’ve been stable for over a year or so now…

Thanks, although it isn’t the same issue since your device was at least talking to the server. My device powers up and runs though all of it’s centering/initialization routines normally. I have checked the support site site, but there is so much clutter in there that it is hard to know if I am missing something. In any case, I have tried redoing the connection to the wifi which was the only thing on the list you referenced that I have not tried that was relevant to the offline issue, and that did not resolve it. I will contact support directly, I was just hoping to not have to have a week of down time waiting for them to respond.

You’ve already contacted support – you opened a support ticket when you posted here. :slight_smile:

1 Like

Yeah, did that as well. But it isn’t a wifi issue… the device is connected to the wifi and communicate with other devices on the network. It is a problem talking the server specifically, so it sounds like I will need to descend into tech support Hades and see if they can figure out what is going on based on their logs.

Yeah, I’ll sit on it for a few days to see if I get a response here and otherwise I’ll contact support directly.

Posting here is contacting support - it opens a ticket, as does sending an email, there is no difference, except they will close this discussion if you’re already communicating via email.

There is a page dedicated to “device offline” errors here.

If the device is offline, you most likely have a wifi issue, regardless of everything you’ve tested. Either that, or the machine is broken and will need to be replaced.

The fastest way to eliminate your local wifi as the problem is to use your phone as a temporary wifi hotspot and connect the machine to that.

1 Like

Just a thought but if you look at the upper right hand corner, you should see your Glowforge’s name and your personal login (mine is different than here) If those are not correct you will see the problems you are having.

1 Like

It’s never lupus. :wink:

Seriously, consider the possibility, to save yourself waiting. Try the cell phone hotspot and other wifi suggestions. Glowforges are notoriously picky about their wifi connections.


I’m having the exact same issue. I connect to wifi no problem, but get stuck on focussing, sometimes it will get to centering. I know it’s not a wifi problem because I also was able to go through setup using a hotspot through my cell phone, successfully connect, but then get stuck on focusing again.

Edit: As I wrote this I was trying again for the 4th or 5th time… took half an hour just waiting a while and restarting etc. But it just connected now. Dunno if they’re having server problems or something.

You need to start your own support ticket by creating your own new post here in Problems and Support. They can only address one customer’s issue per ticket. :slight_smile: (And it still could be a wifi problem. Speaking from long experience, here!)

1 Like

Yeah, I have been through all of that and then some. This is my third Glowforge so I’m pretty familiar with the replacement process.

I’m so sorry to hear that you’re running into trouble, and I apologize for the delay in response.

I’ve extracted the log files from your Glowforge to review, and it is currently connected to your network, without any trouble.

When you are attempting to utilize your Glowforge inside of the Glowforge App, would it be possible to send over screenshots of what you’re seeing when selecting your new replacement unit?

Once we can review these screenshots, we’ll send over the next best steps.

Powered it up last night and it seems to be working fine now. No additional changes on my end, so not sure what is different but the problem seems to have resolved itself.

Thank you for the update. I’m glad to hear that you’re back up and printing! I’m going to close this thread. If you run into trouble again, or have any questions, please post a new topic here on the forum or email us at and we’ll be happy to help.