Engrave doesn't recognize cutout

I was making multiple prints of this design. In between two prints, the text cutout of the design is no longer being excluded from my engrave, as you can see in the preview. The thumbnail still shows the text cutout, however.

I have spent hours trying to fix this but have had no success. Can anyone help?

I use Affinity Designer. Here is the svg file: test|100%

Hmm. Your file looks fine, but it’s doing the same thing to me. And it worked fine before? Same exact file? I wonder if it’s a winding rule thing…

Yeah, that’s it. I took a look in Illustrator – it’s using the even-odd fill rule.

1 Like

I’m not sure how to fix it in AD. :frowning:

I don’t know anything about AD, but the file as uploaded doesn’t have the text “subtracted” from the shape, it’s just additional paths within that object.

I opened in inkscape and used the function to remove it, then saved, and the file shows up like this:

Huh. It was subtracted when I opened it in AD. Weirder and weirder!

Thanks for the responses, everyone! I’ll look for a solution in AD…

Here’s the file I modified:

It is “subtracted”, it’s just subtracted using the even-odd fill rule instead of the nonzero winding rule.

I don’t use Affinity Designer, but I’m a big fan of rasterizing engraves to avoid this whole foofaraw.


I don’t quite understand when I should be using Alternate vs Winding fill. I tried changing it from Alternate to Winding but still have the same issue. Does anyone have any insight into this on Affinity Designer?

Thanks for the tip. I’ll consider rasterizing engraves going forward. Did you encounter this issue with other programs too?

I think this is a “known issue”, if you search the forum you’ll find a bunch of discussion going back years. It seems to bite people who use Affinity Designer. Technically, it’s not doing anything wrong, but the Glowforge software doesn’t seem to understand the way AD combines paths.

For whatever reason, the default behavior of Inkscape and Illustrator is to use the method that Glowforge gets along with.

Now that I know what to research, I think I understand the problem better.

Glowforge Support: Are there any plans to add support for even-odd fill mode? This is how Affinity Designer implements their Subtract operation.

One known issue after another…

And now I’m encountering (again) the issue where my thick Proofgrade plywood does not cut all the way through.

My entire day has been spent working on my GF, but with nothing to show for it…


Usually the first sign you need to clean your lenses. Try that before you get too frustrated!

I just cleaned everything last week. The camera lens, laser lenses, and mirror.

I’ve had this issue before, and it was attributed to the poor quality of my Proofgrade material.

I don’t want to speak for GF, but I wouldn’t hold my breath waiting for a fix. I’m pretty sure I was the first to report it back in 2017 and I’ve been pulling my hair out over this ever since. Please feel free to bring it to their attention once in a while so I’m not the lone voice complaining about it. :wink: FWIW I’m a Corel user, but a few Affinity users have more recently brought it up as well.

If you want to laugh (or cry) about the horribly long road it took the community to figure out there’s a winding rule bug in the GUI, here’s the original link.

1 Like

That’s obviously not an optics issue. Unfortunately, you know the routine for support to diagnose this - GoGM on Medium Draftboard.

Last week is a long time ago if you’re cutting stuff with MDF in it (like PG plywood). It takes longer to open a support ticket by posting here than it does to clean them again, and you might find it’s all you needed!

Worth a shot…

@dan, are there any plans to add support for even-odd fill mode in GFUI? This is how Affinity Designer implements their Subtract operation.