Feedback on my setup experience


#1

First off: This isn’t a request for help - I’m unblocked and have successfully cut out my ruler. This is just some feedback for the team so that things might be improved for future users.

Received my Glowforge on Friday a bit quicker than I expected, so after a bit of office rearrangement (twice :slight_smile:), I unpacked the printer yesterday - this was a great experience: good, clear instructions from the manual and everything looked great. But it was pretty late so I postponed actually powering things on until this morning.

The first hiccup I ran into on the setup process was with connecting to the printer’s wifi. I got through the legal stuff, read through the unboxing instructions (which I had already done with the pdf manual that was referenced in my shipping email) to make sure nothing was different, read through the directions to connect to printer’s wifi, and so did that. I was expecting a webpage to auto load after that connection (similar to the login pages you get when using wifi in coffee shops and the like) but nothing happened. After a few tries on different computers/phones, I was browsing help topics and managed to notice that I was supposed to do this on a page that was then looking for the printer. This caused me to finally realize that the instructions should have said: click continue and on the next page, you’ll do this. No big deal, but not particularly clear - a bit of updating of the text would make this be a non-issue.

Now for the next problem: I picked my wifi, typed in the password, waited while it was trying to connect… “device error”. Hmm, tried it again. And again on other devices. Searched the forums again and found a few ideas to try (like holding the button for 10 seconds to restart the network setup) but nothing helped. At this point I was worried that my wifi setup was causing problems - it isn’t overly strange, but it also isn’t just a simple router. Finally decided to try connecting to my iPhone as a hotspot since that seemed like it could eliminate or identify my network as the issue. This also failed.

At this point I wasn’t what to try but I happened to notice that my hotspot was showing a connection from the printer… interesting. So I decided to just wait. A bit later, my printer made some noises and the teal light went off. Checking apps.glowforge.com and sure enough, my printer was now online.

Finally, I turned off my hotspot, power cycled the printer, pressed the button for 10sec to get the teal light back and went through the setup process one last time to connect to my real network which worked perfectly including prompting me to update the printer name. Printed out the ruler and everything is awesome!

I can only presume that the printer was successfully connecting but doing some additional setup work which was clearly taking longer than the webpage was willing to wait. I could imagine a lot of ways this might be going wrong (I work in the computer software industry) but it would be great if something lit up to indicate it could take a while (presuming that is all that it was and not something else entirely).

Anyway, all is good now, hope this helps to make things better for the future and let me know if anything is unclear or if I can answer any questions.

-Jeff


New Router, Glowforge now errors out on connecting to wifi
#2

I’m happy to hear your Glowforge arrived safely!

Thank you for the suggestions. I’ve passed your feedback on to the team.


#3