File dimensions and laser cut are not the same

I have a class using glowforge to cut parts for a rocket project. They used Adobe Illustrator to create the file and saved as an .SVG file. The dimensions for the product are entered in millimeters.
The print cuts to the correct shape but the size of the print cutout doesn’t match the dimensions specified in the file.

I’m sure there is a simple solution but we can’t figure it out. ANyone have any suggestions?

Yes - AI has a setting that messes with the dimensions. Let me dig up the post.

Here you go - the big one is the “responsive” box:

Welcome to the community! There is a wealth of information here - it’s really the best accessory that comes with a :glowforge: :slight_smile:


Do not use SVG - either copy/paste from AI to the GF interface or use PDF.

Alternatively - place a simple box of known size around all your pieces (12"x20" for example). When you import the artwork SELECT ALL and then use the small ruler icon in the lower left to resize everything to the known size. Delete the box or if it was a different color you can set it to ignore. Now all your pieces will be their correct, original size.


Personally I think SVG is fine to use, you just need to save it with the right settings.

Also, I tested this out when I set up my new computer: if you copy and paste from AI to the GF interface, it uses the last SVG settings you saved with, so it will have the same issue if you’ve never saved an SVG with “responsive” unchecked.


If when you bring the design into the GFUI as the object is highlighted a couple widgets show up at the lower left and when you select them they will tell you the exact overall size of the part selrcted. If you know that number you can type it in and that is the size it will cut.

1 Like

You’re running into problems because SVG files usually specify sizes in pixels rather than real units (such as inches or centimeters). If the program that saves the file doesn’t agree with the Glowforge as to how many pixels make up an inch, then things will be the wrong size.

Three solutions:

  1. Do whatever you need to do to make your SVG get saved at 96 DPI (dots per inch). I don’t use Illustrator so i don’t know its settings, but others here can help with that.

  2. Save as PDF instead of SVG. Because PDF was designed for printing on paper, all PDF files specify sizes in real world units so there should be no scaling issues. There are some minor differences in how the Glowforge software handles PDFs vs SVGs but for the most part you can ignore that for now.

  3. Make your file exactly 20 inches wide and 12 inches tall. When the Glowforge software sees an SVG file with this aspect ratio it ignores its usual DPI assumptions and imports it as 20" by 12". Note: I haven’t tested this in a few years so I’m not sure this magic behavior is still there.


This topic was automatically closed after 30 days. New replies are no longer allowed.