File Upload Error

I am getting the below error message when I go to upload a new file. I have tried restarting my browser, closed out of the dashboard, closed out of my internet browser altogether, turned the machine off, and even unplugged. Still nothing.

Is there a system update going on? Thanks!

An error occurred on your Glowforge. Please refresh your browser before printing. It may also help to turn your Glowforge off and then on again.


Hello, I’m having the same issue, now for about an hour.

1 Like

I am having the same issue for last 30min

1 Like

Yeah I am hoping enough threads and they will have to acknowledge someone and let us know what is going on!

Same issue all morning.

Must be GF issue, I am running into the same thing hope fix soon because I have a lot that needs to get done!!!

1 Like

Also having the same issue for nearly 30 min. Restarted my browser, computer, and GF twice, no change.

I’m glad to see that it’s not only happening to me. I’m not glad that everyone is experiencing this issue but as I spent over an hour trying to fix this issue, I was worried that my machine was broken…again. I hope this gets resolved soon!


Me too!!!

Thought it was just me! Same issue. Can only cut past files can’t upload new. Not great timing with a lot of projects to cut today!

Same issue here. Tried adding a glowforge supplied image using Add → Add Artwork. Same error message. SW been quite buggy the last few weeks.

I have been getting the same thing for over 30 minutes as well. Must be an outage. I have rebooted everything laser/computer etc to no avail. Hope it is up soon. I have a show to process for.

Does glowforge have a server status page?

Good thing is, it seems to be a GF server issue, and not our machines!

I am having the same issue as well.

I am having the same issue as well.

Whew! Glad it’s not my machine. Same here. :slight_smile:

Same problem here, and lot of work needs to be done

Glad I’m not the only one! Guess it’s time to do housework? LOL

Shows everything is online, but definitely not :man_shrugging: