Frustrated! [Resolved]

I’m a new glow forge user and I have to say that so far the experience has been
frustrating. I have been using a Full Spectrum Laser for a couple of years now and
compared to that experience the GF has been like having my hands tied.

As of right now I have a couple of major issues.

  1. I am not able to upload my designs. When I try to upload I get the "Drag you design anywhere
    to upload. When I do that nothing happens. When I select browse nothing happens. I have tried different file formats but to no avail.

  2. The file formats. As an FS Laser user it was extremely straight forward. I work in Rhino. It has very
    powerful and simple vector editing compared to Illustrator. I was able to print directly out of
    Rhino. Simple. I don’t have any software that will export to SVG. I was finally able to get Inkscape to
    accept a PDF and save as an SVG. Still not able to upload a design. PLEASE MAKE THE GF COMPATIBLE WITH DWG. or DXF. FILES!!!

  3. When I turned on the machine today it needed to calibrate. Everything seemed fine until I heard the machine clicking. When I went to see what was happening it was trying to force the head to the left and was jamming itself against the end of the carriage. I had to turn off the machine to get it to stop.

  4. Is there a customer support phone #? I’ve tried to call it once but got the snarky message saying it’s best to use email and wait for a response. Which is great if you are just a hobbiest. But if you are on a deadline it can sink you.

  5. Why can’t the camera see the edge of the cutting area? When I cut the ruler I placed the design to the edge of what I i thought
    was the material which I had placed at the edge of the tray only to find out that there was an inch of
    material to the left of what I thought was the edge of the sheet.


This text will be hidden

1 Like

I felt the same when I got my pro about a month ago. All my experience was also FS laser. I was and still am quite upset with the GF. The hardware seems to be okay but the software stinks.

To me it seems the programmers do not understand how a laser is used and just develop random bits of code just to make the thing do a few tricks. However, the GF could be amazing if it was getting the development support that was marketed in the beginning.

Silly things like I finish a cut and place a new material of the same kind as the previous cut. Get back to my GF and the bed cam did an update of the material I just placed. I then drag a new file onto the material bed workspace and the bed image disappears. Now I have to manually ask for another bed scan so I can place my images to cut. How stupid is that? Why not leave the original bed image so I can place items then cut. If I needed a bed image update I do have that option to refresh in the menu. So with this silly item /feature I lose a lot of time when I’m trying to make production runs.

Regards calibration. That happens every time you turn on the GF which I do not mind that much seeing that it may install new features… I think. Other than the GF likes to calibrate many times a day when in use, which can be again… very annoying.

I have to convert just about all my 3D files to PDF to make anything work correctly. You also have to convert text to paths to get that to work.

My opinion is this laser was designed more for trinket makers and general laser cutting. If you really read the threads it seems that a lot of people use it for engraving and simple cuts. The features that had been marketed was the reason I purchased the GF instead of the FS type that I had been using. Unfortunately none of these features are currently working so the GF at this time is basically a glorified bandsaw with engraving ability.

Hang in tight cause one day a few months/years from now it may have features that had been promised. For now though. You are going to be told that you did sign up for a Beta unit so tough luck.


Yes, I can imagine it would be rather difficult to have to think about doing things a different way once you’ve gotten set doing something a certain way. I’m sorry you’re having trouble adjusting.

  1. SVG, PDF, JPEG, and PNG file formats are accepted at this time by the interface. (There are tutorials available at the link below that explain the best way to set your files up for use in this laser.)
  1. DXF files have been discussed, and as Dan likes to say, they’re in the hopper.

  2. If you don’t turn off the machine when you get that clicking, it will simply finish the calibration. That generally occurs when the head has been moved from the home position, either by hand while the machine is turned off, or sometimes when an update has been rolled out. The head simply thinks it has more room to move than it does and the stepper motor thumps when it reaches the end. (It’s not going to hurt anything, it just sounds scary.) The next time it happens, either let it finish, or just turn off the machine, gently move the head under the lid camera, and turn the machine back on to let it finish it’s startup calibration routine. (Never shift the head by hand while the machine is on, you can damage it.)

  3. No.

  4. The camera displays the current cuttable area of the bed. Due to the need for head deceleration room, the machines don’t access the whole 12" x 20" at this time. That area is being expanded, but it is currently limited to 19.5" x 11" for cutting and somewhat less than that for engraving. If you need to expand the engraveable area, reduce the engraving speed and power.

Any other questions you might have about using the machine just post (one issue per ticket) in Problems and Support and try to be specific about what you were doing at the time that the error occurs. (Pictures and video help get speedy resolution.) :slightly_smiling_face:


Any resolution as to why I can’t upload designs? The app won’t let me upload anything.
Even a jpg. which hasn’t been edited.

If you want to upload them here, someone can take a look at it and see if there’s a problem with the file. (Might be a size issue.)

Thanks for the response.

It seems like we had similar expectations. My FS Laser is ok but my hope was that the GF would
be an improvement in capabilities and quality. There is always a learning curve and some frustration
learning a new way of working.
If I can just get through this part…

1 Like


Here is the SVG file.

What is the file size limit?

Full bed engraves tend to hang up in the buffer at the moment. Let me take a look at the file and see what happens when I try to load it.

As someone who never used a laser other then the Glowforge, I’m quite happy with it but it is a hobby machine and geared to newbies . It wouldn’t compare to a power horse like Spectrum lasers who has been on the market for years. I can see why you would be frustrated as it’s probably a downgrade to the model you are used to.

If you plan to plow through it’ll be a learning curve while they continue to improve the interface and uploads. The forums will be your friend

FYI - if i could afford it I would have went with a more established laser brand. But as mentioned happy so far

1 Like

It should measure 5" x 5".

Yeah, it does…it loaded fine…are you just dragging it over to the dashboard and releasing it?

Which browser are you using? Most of us have found that Chrome works with the least gremlins.

Uploaded and was willing to print… took about a minute to process. I just lied and said I had PG in there to process it using default settings.

What browser are you using?

1 Like

One thing that does concern me about it…looks like there are two engraves right on top of each other. That might be causing a loading issue.

(Any possibility there’s a duplication in there?)

I have the FS Laser Hobby 45w 12 x 20. It was cheaper than the GF.
That being said, my hope is to use the GF as a work horse. I think the user interface
and work flow needs some improvement. Time will tell. Once I can spend some
more time with it I’ll be able to give a more educated opinion. Right now my comments are
born out of frustration.


Pretty design :heart_eyes:

Please Hold…

Just looking at the file (I didn’t pay attention to anything in the design loading it initially) but that has a cut and engrave all on top of each other, which you obviously do not want - as interpreted by the UI.

I brought it into Illustrator and noticed it had a couple of clipping paths applied. The Glowforge hates clipping paths - why? I dunno… probably something that sucks with SVG.

I released the clipping paths and it still has some things in the file - like some of the flourishes are just strokes instead of fills - so they will be interpreted by default as cuts and not engraves.

1 Like

Not sure how that would of happened.

I created the file by starting in Rhino.

I exported that as an Illustrator file which converted the
hatching to fills. Then imported that into Inkscape. Saved as SVG.

Okay, I’m trying to break that up in Inkscape…maybe something in the Illustrator to Inkscape conversion that we haven’t run across yet…that’s a bunch of format changes.