GF Stuck on Focusing

As the title says, my Glowforge is stuck on the “focusing” step. This began yesterday when I first turned the unit on and now it’s all that it does. No noise besides the initial fan whirring and then low RPM hum afterwards. No clicking, no movement, nothing - just stuck on focusing.

I’ve gone through the steps listed here in this post: Stuck Centering/Focusing: How to Troubleshoot for potential Lid Cable issues before contacting Support 😲 two times, just to be thorough and I have read through the other topics that seem to be having the same issue. None of the cables appear to be damaged and everything is relatively clean.

1 Like

I’m sorry that you’ve run into trouble and your unit is stuck on focusing. We extracted the most recent logs from your unit to take a closer look. It looks like your Glowforge was able to connect successfully to your network, but it may be having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

Something I recommend you check first are any security permission settings you might have on your network. To use your Glowforge, you will need to allow access to the following domains on ports 80 and 443, for http and https traffic as well as websockets.

  • *

  • *

Additionally, you’ll need access to the following on port 123 using UDP:

After checking the above, the most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

Please let us know how it goes!


Thanks for your swift response @ivan1. It would seem that my PiHole was blocking and whitelisting the address seems to have allowed the Glowforge to begin functioning again. I’ll be testing it out further this afternoon and I’ll respond with the results to say if it continues to work.


Seems like things are going smoothly! Thanks so much for your help!

Hi @Gequinn, I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!