GFUI - designs take forever to load and then laggy

I noticed just a few days ago that suddenly the GFUI is super laggy. I am trying to print the spiro toy. I have all three layers loaded into the GFUI. I am waiting for the design to load as we speak, it’s been 3 minutes with the ‘Rendering your design’ message. When the design does render, it’s super laggy when I try to drag parts around.

My down/up internet speed is 90/10Mbps. When I try to load or move a design, my system is at about 40% CPU load though the Google Chrome Helper process does appear spike above 100% of the CPU. This is a new problem and I haven’t made any changes to my system. Any idea what’s going on and how I can fix this?

Try rebooting your computer?

I just opened one of my most complex designs, took just seconds and then moved around as fast as I could move the cursor.

Ok, tried that. Same laggy performance :disappointed:

May be network traffic–I find some periods/days are slower than others…

I’m pretty sure that once the design is loaded and on the screen, the work is happening on your local computer, so dragging things around should not be affected by the network.

Are other things on the same computer slow? Maybe there are some background processes going on or some unwanted software in the browser. Perhaps try opening the Glowforge app in an incognito window with plugins disabled?

Correct. You can even disconnect from your network and the UI will work as normal.

I’m so sorry you ran into trouble with the Glowforge app! There is something else you could try as well. Could you please clear the cache and cookies on the browser you are using and try again?

Let us know if that helps.

That is really helpful to know that the rendering is offline once the design is loaded. Thank you for that tidbit! I tried again in Incognito mode and there was no improvement. I’m noticing this is only an issue for my most complex designs so must be something to do with resources.

Thank you for those details! I would like to take a look at one of the files that you are encountering this trouble with. Could you please send us one of those files? You can either post it here or you can email it to, whichever you prefer.

Awesome! The file I’m using is pages 1 and 2 of the spirograph design. Both are loaded into the GFUI.

And clearing browser history didn’t fix the issue :confused:

Thank you for those details and for trying that. I’ll need a bit more information to investigate further. Please do the following:

  1. Go to
  2. Click the link underneath “Share my system info with tech support”.
  3. Copy the highlighted link.
  4. Reply to this and paste in the link provided, or you can email it to if you’d prefer.

Thanks in advance!

ok! info is sent via e-mail to

I see you already emailed us about this and we’ve responded with the next steps there, so I’m going to close this topic.