GFUI Website Buggy

The GFUI has been super buggy for days. Even if I clear my cache files, try different browsers, it keeps crashing and can’t do basic things. Anyone else having problems? It will take me an hour before I can get a print to even load. I’ll select a material and the whole website crashes. What is going on here?

Have you tried using a different wifi network? (for your devices, not the GF) I haven’t had any GFUI issues lately.

Yeppers. Not just the GFUI, I’ve been working off a hotspot since yesterday afternoon…our ISP is having SSL issues. Can’t get into anything.

Good day to work in the yard or read a good book. :slightly_smiling_face:

If only I could. I have about 60 orders waiting to get shipped.

@TimothyHand are these your own designs or are they glowforge designs?



These are my own designs that I have been using on my Glowforges for years. Shouldn’t be an issue with the file.

That sounds like a Wifi problem. I had an issue a few weeks ago and the first I noticed it, it was the GFUI. and it was a while before I saw other things go wonky. Between the computer, the Glowforge, and the mothership, the conversation can get a bit complex.

Speed test says that I am 212.4 Mbps download and 6.71 Mbps upload

1 Like

@rbtdanforth makes a good point, how about holding down button on GF (till its teal) and re-establishing connection with WIfi - make sure that the Glowforge is communicating properly.
wouldn’t hurt . . .


1 Like

Sadly it’s not speed you need to check for, it’s reliability. If it’s dropping packets the :glowforge: doesn’t buffer (like movies) it has to start again.

Can you try this:


this is also what the speeds are from your computer, not the GF. if your GF is not communicating well with your router, for whatever reason, that will cause problems.

i used to occasionally have problems with my GF communicating w/the router. i’d get occasional offline moments or have designs take a long time. my router was downstairs from me, and all of my other devices communicated fine. my UL/DL speeds from speedtest were consistently 300/300 from my devices.

then at the beginning of this year we switched to a mesh system and one of the mesh hubs is now in my studio/office area, and i almost never have that issue now.

we’ve seen a number of people have issues with the GF communicating with their router (and thus with the GF servers). my guess is that’s the issue you need to resolve.


Not sure what it means.

That may work if I were having issues with my GF units. But the issue is with the GFUI web app. It won’t open files that I’ve been using on it for years. It is all buggy in the controls. I can’t grab and drop images, but I can use arrow keys to move it. It will crash suddenly when I select materials. This wouldn’t be because my GF unit isn’t connected to the internet.

It shows 0% packet loss - which should mean a solid connection. I’m not sure what else to suggest :-/

Actually, I do have one more - I don’t see anywhere that you’ve tried rebooting your router. Worth a shot eh?

1 Like

if you are having issues, but others aren’t, then it likely points to something that’s going on with either between your laptop and the GF servers, or it’s something going wrong in your browser.

i would work on the browser possibility first because you can do a lot of that before GF responds.

1: have you tried different browsers?
2.: do your browsers have adblocking plugins? i would try with those disabled.
3: if that doesn’t work, i would open in an incognito tab and try that.

in the end, it’s very possible something in one of your plugins (if you have any) that is disrupting the GFUI. so any way you can isolate your browser from plugins being turned on, you could figure out which one is creating the problem.

1 Like

i used my GF last night for 3 hours (~10 pm to 1 am) and noticed that from 10:30 pm to 11 pm Pacific, i was having issues with the UI loading and opening my files. whether it was loading a file i have already cut from the UI or dropping the same file from my computer, it was stuck at rendering. i ended up shutting off the GF three times, waiting a couple of minutes before turning it on again, and then it would work. after that, things went back to normal so i don’t know why for half an hour, it wasn’t behaving normal. (no, i didn’t do anything else but turn off my GF on and off.)

I came to this because I was having the same issues, so you are not alone. have you found a fix?

Not as of yet. I have noticed it seems a little less buggy today. I wonder if they did an update on the GFUI.

Yeah something happened with the update they did they created a incident report so hopefully it will be fixed soon

HI @TimothyHand. I apologize for the delayed response and we made some recent updates to the Glowforge app to address some issues customers were experiencing around the times you were last writing us. If you haven’t already done so, can you try logging out, refreshing the browser, and logging back in and giving my any update on any issues still encountered? I appreciate your time checking this and will look forward to hearing back. Thank you!