Glowforge app is adding vectors to passthrough items

If you see drawing at first without passthrough and then in pass through it is adding vectors to the top of the first passthrough image

in pass-through

image in illustrator with no clip art

Welcome to the forum.
I am sorry, but I don’t understand your question or problem.

I assume it’s in this image that we see the problem?
In the upper right?

I’m not sure if it’s passthrough specific… but maybe you have some weird unclosed path?

Have you tried this same image resized down smaller? Just as a test?


Looks like you have an open path. Often it’s two nodes on top of each other. You can look for them manually, or some programs have auto-searches for them.


yes its the top, right. it is not a open path as stated by another this has worked over 15 times on the same template only thing that changes are the monogram and letters. its adding a vector shape in automatically. its not shown when not in passthrough and also I didn’t design it that way

I have no open paths, they are all united and closed.


Smaller resized image does not show the artifact

I’m out of quick ideas to check.

If you feel comfortable sharing the artwork, I’d be happy to look at it a bit and see if I see anything weird.

Otherwise you might need to wait until someone from Glowforge can look closer at this with you.

Good luck!

1 Like

Here you go.
Budd2.pdf (364.1 KB)

also to add to this while testing it only does this when pressing print to get it loaded into printer in passthrough

My printer’s off right now, so I can’t try to reproduce the error, but I did make some tweaks to your file…

Mostly tried to clean up the blue portion of the image.

There was some spurious anchors and I think I found some open paths.

I tried Unite’ing everything a few times =P then making one big compound path out of all the blue stuff. I’m not sure it’ll make any difference, but if you want to try my version, here it is:
Budd2-fixed.pdf (372.4 KB)

Note: the Adobe Illustrator “clean up path” tool doesn’t look for open paths, as far as I can tell:

thanks I appreciate this and let me try this, I have used this exact template many times I was weird seeing this pop up when it hasn’t before. Will let you know in a few hours.

My guess is when Glowforge splits you artwork somehow for the passthrough, that maybe it splits something in a way that confuses it.

It very well may be a bug on Glowforge’s part, but you may be able to work around it by cleaning up your artwork.

Good luck! Hope it works!

I’m sorry for the trouble while using Pro Passthrough. It’s great to see that you’ve already received some advice from another Glowforge owner! Please let us know how things go.

Something else you could try would be to convert the engraved portion of your design to an embedded image by rasterizing it. Here is a guide showing how to do so in either Inkscape or Adobe Illustrator: Rasterize Objects

1 Like

Big +1 to that. That’ll avoid any weirdness with the paths all together.

it didn’t work, its even more pronounced. This template has been working for the past 2 months, this is maybe to do with something on glow forges end. Rasterization will work but the look will change completely.

I’m sorry to hear that things didn’t improve. Are you still working with the version of the file titled “Budd2.pdf” that you shared earlier on in the thread? If so, I’ll use that file on my end today to try a few more things on our end and look into this further.

yes, but also tried the revised version that was provided by Jestelle

You should be able to address this with rasterization without anything changing visually.
You may need to make sure you use a high enough DPI so you don’t lose details.


I just wanted to jump in and let you know that we are still investigating the trouble that you are seeing. Will update as soon as we have more to share!