Glowforge doesn’t turn on laser

I’ve put in proofgrade material, doublechecked power settings, the mirror is in great shape, and the lens (while it does have a small scratch, and there’s a second on the way) seems fine.

The Glowforge had been sitting untouched for a while, over a year, and this is the first time I’ve tried to cut with it since then. Ideas? I’m stumped for what to test next.

Does the Glowforge power on?

1 Like

Yes, sorry. It powers on, centers, receives the go ahead to print, ‘prints’, but the laser isn’t coming on and doesn’t cut.

Do you have a screen shot of what your interface looks like? Including you settings and all in the image really helps.

Cut, max power, proofgrade cherry hardwood. Using any shape, so far. Nothing unusual or custom at all, just picked a pico puzzle and print.

Not sure if your screenshot is incorrect, but you won’t get much cutting with 500 speed.

1 Like

Why not use Proofgrade settings?

1 Like

In the 20 or so tests I’ve done with custom and proofgrade settings, NONE of them have made any difference to whether the laser turns on. The head moves, the laser does not turn on and no mark is made on the paper.

1 Like

For reference: Identical results.

Do you see any light/plasma action in the tube when it’s supposed to be cutting? That will help decipher if the tube is working and if you have something wrong in the optical path somewhere.

For reference, here is what support will probably ask of you: Laser head moving, but not firing - #5

So I would go ahead and upload pics of the lens, mirror, and the two laser windows to help get them the info they need.

No, the laser tube itself never illuminates at all. I’ll post the requisite pics later.

Well my glowforge is also not firing the laser. it started this last sunday but i just now got time to look at it today. I went thru all the checks and still it doesnt work. Maybe we can get a response from them at some point.

As mentioned, here are the pics of the various lenses and the mirror.

My laser also doesn’t turn on tonight (Plus model). Head just moves around. Cleaned. Checked connections. Last used it successfully on Oct 14th.

Hi and welcome to the forum @gmikewilliams and @mark.chandler. This section, Problems & Support, is where you make a post if you need help with your machine from Glowforge’s staff. Posting here opens a support ticket with them. However, commenting on someone else’s ticket won’t create a ticket for you and won’t get you help with your machine. You need to make a post of your own, or email, or use the live support chat during business hours.

1 Like

really? its also for the owners to discuss problems and support them as a group.
You make tickets at support@glowforge. its alot faster. I guess mark and i were making the statement that alan is not the only one with this problem.

I’m sorry if I was unclear. You said that you were having a problem with your machine and wanted a response from the staff. To get that response, you’ll need your own ticket, whether you open it by email or by posting in this forum on your own. I just wanted you to know that you won’t get help with your machine by commenting in others’ tickets. You’re free to do so for any other reason of course.


Still no luck with the laser, after several cleanings, shut down / restarts, and checking the cables that I can see / access, the tube never lights up, the head moves as if its cutting, but no actual progress.

me either. waiting on support to get back with me