Glowforge is not powering on

I have a Glowforge that is approximately six months old. It was used maybe once per week. Recently, it has not been powering on. There is power to the Glowforge (first thing I checked), and the switches are all in the correct position. There are no signs of life at all. I was wondering if there was a circuit breaker or some other switch that I need to look for? Thanks in advance for any and all help. It is greatly appreciated.

On the pro (and possibly others?), there is a funky little circuit breaker on the back near the power switch. It has a piece of metal sticking out of it. That could be your issue if it is not fully seated.

Thanks for the response! Mine is the plus not the pro. There is nothing back there besides the power input and switch.

The only other thing I can think to try, if possible, is to find some piece of electronics like a laptop power supply, a printer, a computer or monitor that uses the same type of power cord, and swap it out to see if that helps.

Beyond that, I’m not sure what else you can do.

(I personally would use a test meter to check that there is power coming out of the existing power cord, but not everyone has one, or is comfortable messing with mains voltage…)

Thanks again for the advice. I checked with three other cables and also with a multimeter. The Glowforge seems to be dead. Again, thanks for the advice. I appreciate anyone that can help me. I need this for an upcoming project.

I’m afraid the only option is likely going to be sending it back for repair. Support will need to weigh in though. Sorry.

Good news, however, is that the warranty on the Plus is 12 months. While I’m sure it will be painful to have to ship it back, at least it will be under warranty.

Best of luck.

1 Like

How do I send it back? Where is the best place for warranty support? I literally got rid of the box it came in last week.

Support will handle that once they determine it’s the correct course of action.

That’s unfortunate. A new box and shipping materials is going to cost you $250.

If you know someone else (locally) that has a forge, you might be able to levy them to lend you their box, with a promise / pledge of replacing it if it were damaged as part of the return / exchange /repair process.

Just a thought.

2 Likes

I’m so sorry to hear that your Glowforge isn’t powering on. I extracted the logs from your printer and saw that yesterday it was able to was able to connect successfully to your network, but it may be having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

Could you please let me know the approximate time (with time zone) that were having trouble with the unit not turning on?

Hi, we are EST and the unit has been doing this for about a week at least. There have been no signs of life and I finally had some time to get to it yesterday and today. I also just tried resetting the network settings using the button hold while turning it on and there is still no sign of anything at all from the printer. No lights turn on, there are no sounds, no network traffic. Please let me know what I should be doing. Thanks in advance!

Thank you for confirming that information for me. I extracted the new logs from your printer and saw that the unit did connect on our end when you turned the power on today.

I will need to check over a few more things before I can advise about next steps.

Could you please post the following photos?

Assuming you’re using a smartphone, try these tips for great photos:

  • Use flash
  • Zoom in using the digital zoom
  • Hold the camera/phone far enough back to get good focus.

Here are the photos:

Motor on the laser arm (and surrounding):

Inside, left of machine:

Pull the laser arm all the way forward.

Reach over the laser arm, and to the left of the inside of the unit and you’ll see this circuit board:

Left side of front door:

None of the pics and gifs support keeps posting from atlassian.net are visible to members here.

2 Likes

Are you sure it’s not some limitation with your browser @eflyguy? I can see them fine. (Are you viewing on a tablet or small device?)

1 Like

Same here. Can’t see the circuit board picture. Probably links to an employees only server.

2 Likes

Yes. I’m on a MacBook. When I go to those links directly, it takes me to a login page for “Confluence”. I can see, for example, the three Zendesk-hosted images Ivan posted, but not the 3rd one which is linked to Atlassian. Many others have commented they can not see those images.

Ahhh, okay…didn’t even realize there was a fourth image in there. Yeah, can’t see that one either.

Hi folks, thank you for letting us know that the photo wasn’t showing up on the forum.

Please let us know if this version of the circuit board photo below doesn’t show up.

2 Likes

It’s there now.

1 Like