Glowforge not powering on?


#1

I’ve unpacked my GF basic. removed the shipping anchors, connected the head, exhaust hose, power cable, flipped the switch and… nothing?


#2

that’s unfortunate. is it plugged directly into an outlet? is the power cord firmly seated in the plug in the rear?


#3

yes and yes


#4

The outlet for sure has power? plugging in a lamp works ok and there’s no switch or anything?


#5

presumably you’ll have to get it replaced, i guess, but i obviously can’t tell. hopefully support has a better idea. you might try a second power cable if you have a PC desktop lying around, but those cords rarely fail. i guess aside from making sure that outlet is turned on… :frowning:


#6

I actually tried another cable already.


#7

argh, can’t imagine how frustrated you’re feeling, heh.


#8

Checked the outlet by plugging in a lamp to it and turning it on?


#9

Uploading…

Slight update… as I was typing this, I heard it magically power on for a moment, heard some bubbling, the LEDs powered up, and I was about to feel really foolish because maybe I just needed to wait for a second… but… nope, then it stopped, and it won’t turn on again.

I ran it to another outlet as well, before anyone suggests that. Same effect.


#10

Okay… It is turning on again… lets see if this time’s the real deal? Perhaps the heat of the trip was just too much and had to cool down before actually powering on?


#11

:crossed_fingers:t3:

hope so


#12

hmmm, just finished the setup, and it shut down. thinking it was going to sleep… and now its not waking back up again?


#13

Are you having a heat wave there? I really hope you get it online soon, how stressful this must be!


#14

It seriously might have gotten very overheated in the truck. You should let it cool off before trying to fire it up. (You’re in New Orleans? Give it a while. The fluid temp has got to get down to the mid 70s.)

Mine sat for eight hours inside until hubs came home to help me lift it - it might take that long for hot climates.


#15

This is the one thing I’m hoping on. It’s powered up multiple times before shutting back down. For an initial experience, this hasn’t been very pleasant, but I’m hoping it’s just environmental factors and not faulty hardware.


#16

Not powering up as in the lid LEDs are not turning on? Or not ‘powering up’ as in a job will not start? (You would be seeing an orange lid button.)

If it’s no lid LEDs- check if the power switch is in the fully on position (not in-between on/off) and that the power cord is fully seated. If all that checks out- as everyone has said- contact support. But I’d leave it off until they get back to you. It unlikely it’s a thermal issue if it’s flat not turning on.


#17

Dang it! First the full truck, now this. Hope it all starts looking up soon!


#18

#19

Now it’s doing this. :point_up_2:


#20

Yeah. Power down and wait for support. You may want to keep the boxes close by.