Hello! Really hoping someone here can help! I have to fulfill orders ASAP before I go out of town for 2 months… Yesterday my GlowForge worked perfectly. Today I went to turn it on and nothing happens, no lights, no centering, no movement, nothing at all as if the machine is still off. I check the wall outlet to make sure the outlet is working, and its working fine on any other devices.

Any ideas?!? The live chat I guess isn’t available right now. THANK YOU

Did you check the circuit breaker next to the switch?

please explain more, didn’t know there was one. what do I need to do with it? thanks for the super fast reply!

On Pros there’s a metal staple next to the switch on the back of the machine, if it goes dislodged the machine won’t work

Yes I see that, seems tight, does it pull out? or how can I check that

No, if it’s in tightly that’s where it’s supposed to be :-/

ahh dang. okay I guess its not that. If anyone else has any ideas its much appreciated!!

Also check where the power cable plugs into the back of the machine?

I unplugged the machine and from the wall and plugged it all back in and still nothing =[

No, I meant the other end of the cable that plugs into the machine. Is it still pushed all the way in?

yes. all the way in on that end also

There are cables that run across the lid (shown in the picture here) - are all of those connections closed? Does the cable look crimped or damaged where the green oval shows in that photo?

Looks all good. Ill attach some photos though.

I see you are in good hands, I was looking for the image @deirdrebeth showed you. I am sorry I don’t have any better ideas than others have outlined. I would still try a different outlet to plug into as there is not much difference between making a connection and not. even wiggling the plug a bit could at least alert you to the source of the problem.

Thank you, I tried another outlet, but still nothing unfortunately =[

Well unfortunately, I think Support is going to have to take a look at your logs to see what’s going on. It’s possible that lid cable where the green oval shows got worn and broke (it’s an easy fix with a replacement cable) but there’s no way for us (or you) to be able to tell if it broke inside. You might try wiggling it just a slight bit and see if the power comes on.

ill try that now. thanks!

Unfortunately nothing =[ Id be shocked if it was a cable. Ive only owned the machine for about 2 months =[

It might still be the cable…they had a small spate of problems with them a few months back. If they pull tight against that little metal ledge on the lid when the lid is opened fully upright, it can stress the wires inside. (I don’t open the lid fully upright - it’s designed to stay open.)

Anyway, I think they can tell by viewing the logs, so good luck. :slightly_smiling_face:

1 Like

Ahhh good to know. Thanks so much for all you’re help!